Bug 8331 - permission problem
permission problem
Status: RESOLVED WORKSFORME
Product: Samba 3.5
Classification: Unclassified
Component: Winbind
3.5.8
All All
: P5 critical
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-28 07:06 UTC by GONZALO
Modified: 2018-03-27 21:41 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description GONZALO 2011-07-28 07:06:53 UTC
Hello,
I'm using samba 3.0.28 with winbind in an AIX 5.3 server as a file server.
I have set inherit permissions = yes and now if I create a folder, permissions are set  correctly. I have full control for owner and group and execute for everyone.The problem is that when a user from the group which has full control creates a file the permissions are set as full control for user but special for group, so group members can not delete the file.
Tkanks for your support
Comment 1 Björn Jacke 2011-07-29 20:52:42 UTC
3.0 is unsupported since ages. I think latest samba vesions have a correct working "hinherit permissions". If you see such a misbehaviour with the latest 3.5 release please reopen this bug against that version. Thanks!
Comment 2 GONZALO 2011-08-03 06:54:48 UTC
I have migrate samba to 3.5.8 and I have the same problem with "inherit permission".
I set it in my smb.conf and set the acls from windows on a folder.
If I set "full control" for a windows group on a folder and I create a folder within it , the folder inherit permissions correctly but If I create a file the file does not inherit "Full control" but "special" permission , and users from that group are not able to delete the file.
This is a big problem when you safe a file in applications as Catia that create a temporary file when you save that needs to be deleted.
Comment 3 GONZALO 2011-08-03 08:19:35 UTC
Hello,

I have migrate samba to 3.5.8 and I have the same problem with "inherit
permission".
I set it in my smb.conf and set the acls from windows on a folder.
If I set "full control" for a windows group on a folder and I create a folder
within it , the folder inherit permissions correctly but If I create a file the
file does not inherit "Full control" but "special" permission , and users from
that group are not able to delete the file.
This is a big problem when you safe a file in applications as Catia that create
a temporary file when you save that needs to be deleted.

Thanks !

Gonzalo Ortega 

Organización y Sistemas  



-----Mensaje original-----
De: samba-bugs@samba.org [mailto:samba-bugs@samba.org] 
Enviado el: Friday, July 29, 2011 10:53 PM
Para: ORTEGA DOMINGUEZ, GONZALO
Asunto: [Bug 8331] permission problem

https://bugzilla.samba.org/show_bug.cgi?id=8331

Björn Jacke <bj@sernet.de> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |WORKSFORME

--- Comment #1 from Björn Jacke <bj@sernet.de> 2011-07-29 20:52:42 UTC ---
3.0 is unsupported since ages. I think latest samba vesions have a correct
working "hinherit permissions". If you see such a misbehaviour with the latest
3.5 release please reopen this bug against that version. Thanks!
Comment 4 Björn Jacke 2018-03-27 21:41:25 UTC
without having a close and direct look at that setup I think there is not a lot we can do. This looks more like an issue caused by an AIX specialty or the way Samba is set up on that box. Some commercial samba support might help you out, see https://www.samba.org/samba/support/globalsupport.html