Bug 8295 - It' not possible to connect to non home shares
It' not possible to connect to non home shares
Status: RESOLVED INVALID
Product: Samba 3.5
Classification: Unclassified
Component: File services
3.5.9
Other Windows 7
: P5 major
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-08 05:46 UTC by fyysh
Modified: 2011-07-08 08:42 UTC (History)
0 users

See Also:


Attachments
W7 error message (34.46 KB, image/png)
2011-07-08 05:46 UTC, fyysh
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description fyysh 2011-07-08 05:46:06 UTC
Created attachment 6675 [details]
W7 error message

Hardware: x86 & x64

I'm using smb on FreeNAS 8 (v8.0.1. beta 3) and I'm having an issue connecting to the shares.

Here's my smb.conf: http://pastebin.com/yTyeZBpB

On the Windows 7 machines (i tried on several) I'm able to connect to the home directory share, but connecting to the share "test" will always give an error message (screenshot attached).

Connecting to the share "test" works fine with Ubuntu, PCBSD, OSX (10.4, 10.5, 10.6 & 10.7) and Windows XP.


On the W7 machines I tried:
- Enabling "LM and NTLM – use NTLMV2 session security if negotiated"
- Disabling require server side 128 bit encription

On the server the share has the same permissions and ownership as my home folder.



Here's the output in my smb log when i first try to connect from a W7 machine to the share "test":
http://pastebin.com/eGAkmi6k

At this point I'm being asked to enter my credentials (which are not the same username/pw of the Windows user account btw). I get the error message but after dismissing it i can see my home directory share.

That's what i get when i connect to the home directory share which works fine:
http://pastebin.com/bBhfEStZ

Then, when i try to connect to the share "test" again, i get this:
http://pastebin.com/t3PQx63r



The main developer of FreeNAS 8, Josh Paetzel, said that there are several users reporting this issue bit it works fine with his W7-test machines.
Comment 1 Volker Lendecke 2011-07-08 08:08:40 UTC
Try without "vfs objects = zfsacl". There seems to be an issue with that. Maybe you did not enable NFSv4 acls in the kernel or filesystem?

Volker
Comment 2 fyysh 2011-07-08 08:42:48 UTC
Hi Volker,

yes, that's it! Removing "vfs objects = zfsacl" solves the problem!
Now I also understand the issue - it's a FreeNAS 8 issue. I'll comment the solution in their bugtracker.
https://support.freenas.org/ticket/504 


Thank you so much, Volker!