Bug 8292 - Disable SMB2 for 3.6
Disable SMB2 for 3.6
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: File services
unspecified
All All
: P1 regression
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks: 7803
  Show dependency treegraph
 
Reported: 2011-07-07 15:08 UTC by Volker Lendecke
Modified: 2011-07-13 19:31 UTC (History)
2 users (show)

See Also:


Attachments
Patch (1.60 KB, patch)
2011-07-07 15:08 UTC, Volker Lendecke
jra: review-
Details
Metze's patch for 3.6.0. (3.37 KB, patch)
2011-07-07 21:27 UTC, Jeremy Allison
no flags Details
Non-essential patch to move functions to the place where they are used. (9.51 KB, patch)
2011-07-07 21:57 UTC, Jeremy Allison
jra: review? (metze)
Details
Patch for v3-6-test (12.11 KB, patch)
2011-07-11 19:42 UTC, Stefan Metzmacher
vl: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volker Lendecke 2011-07-07 15:08:02 UTC
Created attachment 6669 [details]
Patch

A major architectural flaw has been found in the 3.6 SMB2 server code.
Comment 1 Jeremy Allison 2011-07-07 16:05:21 UTC
Comment on attachment 6669 [details]
Patch

I'm sorry, but I don't think this is the right solution. We can't abandon this at this point. If we need to delay 3.6.0 to review we need to do this instead of removing the key 3.6 feature.

Jeremy.
Comment 2 Volker Lendecke 2011-07-07 17:34:29 UTC
There are many more key 3.6 features. We have lived without SMB2 for years, and the earth will not come down if we defer that to Samba 4.

Volker
Comment 3 Jeremy Allison 2011-07-07 21:27:43 UTC
Created attachment 6671 [details]
Metze's patch for 3.6.0.
Comment 4 Jeremy Allison 2011-07-07 21:32:55 UTC
Gah, sticky mouse - clicked submit too soon. 

https://attachments.samba.org/attachment.cgi?id=6671

Is the patch Metze posted on the list. Works for me.

Jeremy.
Comment 5 Jeremy Allison 2011-07-07 21:34:02 UTC
Comment on attachment 6669 [details]
Patch

I think Metze's patch obsoletes this.
Comment 6 Jeremy Allison 2011-07-07 21:57:09 UTC
Created attachment 6672 [details]
Non-essential patch to move functions to the place where they are used.

Metze and Volker, here is the (optional) change on top of the metze's patch to make the code paths in smb2 clearer. Please review for 3.6.0 final.

Thanks !

Jeremy.
Comment 7 Stefan Metzmacher 2011-07-11 19:42:47 UTC
Created attachment 6679 [details]
Patch for v3-6-test

I've skipped the move patch for v3-6-test as it doesn't apply cleanly.
Comment 8 Karolin Seeger 2011-07-13 19:31:22 UTC
(In reply to comment #7)
> Created attachment 6679 [details]
> Patch for v3-6-test
> 
> I've skipped the move patch for v3-6-test as it doesn't apply cleanly.

Pushed to v3-6-test.
Closing out bug report.

Thanks!