Bug 8244 - Cannot copy files larger than 2 GB to Samba share
Cannot copy files larger than 2 GB to Samba share
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: File services
3.6.0rc2
All All
: P5 major
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-17 19:53 UTC by Christian Ambach
Modified: 2011-06-21 18:10 UTC (History)
0 users

See Also:


Attachments
proposed patch (1.56 KB, patch)
2011-06-17 20:01 UTC, Christian Ambach
vl: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Ambach 2011-06-17 19:53:20 UTC
Windows clients cannot copy files larger than 2 GB if time_audit VFS module is used, because the module messes up the allocationsize in the NtCreateAndX reply.

Problem is caused by the module using int to store a uint64, so the upper bits get messed up

Patch is coming through autobuild
Comment 1 Christian Ambach 2011-06-17 20:01:36 UTC
Created attachment 6596 [details]
proposed patch
Comment 2 Christian Ambach 2011-06-20 08:07:08 UTC
Karolin,

you can cherry-pick bb66504 from master.
Comment 3 Karolin Seeger 2011-06-21 18:10:10 UTC
(In reply to comment #2)
> Karolin,
> 
> you can cherry-pick bb66504 from master.

Pushed to v3-6-test.
Closing out bug report.

Thanks!