Bug 824 - Unable to lookup group mappings sambaGroupMapping
Unable to lookup group mappings sambaGroupMapping
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.0
Other other
: P3 normal
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-27 02:48 UTC by Tomas Edwardsson
Modified: 2005-08-24 10:18 UTC (History)
0 users

See Also:


Attachments
Output of "net groupmap list" with debug set to 9 (1.44 KB, text/plain)
2003-11-27 02:48 UTC, Tomas Edwardsson
no flags Details
Output of "ldapsearch -x '(objectClass=sambaGroupMapping)' ou=Group" (403 bytes, text/plain)
2003-11-27 02:49 UTC, Tomas Edwardsson
no flags Details
The smb.conf used by the server (13.04 KB, text/plain)
2003-11-27 02:49 UTC, Tomas Edwardsson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Edwardsson 2003-11-27 02:48:12 UTC
Attaching what I think is relevant.
Comment 1 Tomas Edwardsson 2003-11-27 02:48:43 UTC
Created attachment 274 [details]
Output of "net groupmap list" with debug set to 9
Comment 2 Tomas Edwardsson 2003-11-27 02:49:30 UTC
Created attachment 275 [details]
Output of "ldapsearch -x  '(objectClass=sambaGroupMapping)' ou=Group"
Comment 3 Tomas Edwardsson 2003-11-27 02:49:50 UTC
Created attachment 276 [details]
The smb.conf used by the server
Comment 4 Gerald (Jerry) Carter 2003-11-27 07:09:40 UTC
I think this is a bug caused by the ordering of the various suffixes 
and has been fixed in the lkatest SAMBA_3) cvs (for 3.0.1).
Try setting the ldap suffix first:

  ldap suffix = dc=os,dc=is
  ldap user suffix = ou=People
  ldap group suffix = ou=Group
  ldap machine suffix = ou=People

And please test the current 3.0 cvs tree as well.  Marking 
this one as fixed.  If it still exists in the current SAMBA_3_0 
cvs code, please reopen the bug report.  Thanks.
Comment 5 Gerald (Jerry) Carter 2005-08-24 10:18:23 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.