Bug 8236 - "Printer properties cannot be displayed" warning when trying to see printer properties
"Printer properties cannot be displayed" warning when trying to see printer p...
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: Printing
3.6.0rc2
All Windows XP
: P5 critical
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-14 15:18 UTC by Guenther Deschner
Modified: 2011-09-15 18:29 UTC (History)
1 user (show)

See Also:


Attachments
patch (1.03 KB, patch)
2011-09-02 15:06 UTC, Andreas Schneider
jra: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guenther Deschner 2011-06-14 15:18:02 UTC
"Printer properties cannot be displayed" warning when trying to see printer properties

It works with Windows7 though.
Comment 1 Guenther Deschner 2011-06-14 15:39:32 UTC
Looks like this is caused by an empty hostname in _spoolss_RouterRefreshPrinterChangeNotify() when sending a PRINTER_NOTIFY_FIELD_SERVER_NAME notify.
Comment 2 Jeremy Allison 2011-06-23 16:47:20 UTC
Guenther, where should we set this in the reply to ensure a non-null hostname ? I'm looking into this now..

Jeremy.
Comment 3 Andreas Schneider 2011-09-02 15:06:37 UTC
Created attachment 6852 [details]
patch

This should fix it. At least I didn't get the error message gd described with WinXP.
Comment 4 Jeremy Allison 2011-09-02 23:27:43 UTC
Comment on attachment 6852 [details]
patch

Looks good to me for 3.6.1.
Jeremy.
Comment 5 Jeremy Allison 2011-09-02 23:28:21 UTC
Re-assigning to Karolin for inclusion in 3.6.1.
Comment 6 Karolin Seeger 2011-09-15 18:29:07 UTC
Pushed to v3-6-test.
Closing out bug report.

Thanks!