Bug 8167 - User-authentication
Product: smbta
Classification: Unclassified
Component: websmbta
All All
: P5 enhancement
: ---
Assigned To: Benjamin Brunner
Depends on:
Blocks: 8204
  Show dependency treegraph
Reported: 2011-05-25 16:14 UTC by Benjamin Brunner
Modified: 2011-06-21 13:51 UTC (History)
2 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Brunner 2011-05-25 16:14:58 UTC
Adding a user authentication to websmbta
Comment 1 Benjamin Brunner 2011-06-20 15:36:16 UTC
Implemented a user authenitacion on Devel.
Holger could you try it, please. And if you have any suggestions, please tell me.
Also notice the change in the README that you have to run "rake db:migrate"
to create the initial database.
Comment 2 Holger Hetterich 2011-06-20 16:40:26 UTC
Benjamin, is it running on seizewell?

I am going to run it locally if I find the time. Much other things are consuming my time while on vacation.
Comment 3 Holger Hetterich 2011-06-20 16:48:27 UTC
Thank you Benjamin for this effort. I need to test it as soon as possible. Do you personally think this feature can settle down stable and can block bug#8204 ? ( Note: we are currently "far" away from 1.2.6, as I have to dig through some ugly changes in the database handling, so there _is_ time).
Comment 4 Holger Hetterich 2011-06-20 16:51:18 UTC
If you think it's worth for 1.2.6, keep in mind that updating the documentation (not the readme) is a must.
Comment 5 Benjamin Brunner 2011-06-21 08:42:50 UTC
Holger, the authentication is already working. I'll write the documentation today.
If you want to test it, please contact me in IRC and you can try it on slayer.
Comment 6 Benjamin Brunner 2011-06-21 13:51:35 UTC
Also added documentation for user-authentication and marked as block for 1.2.6.