Bug 8162 - MKDIR Fail
MKDIR Fail
Status: RESOLVED DUPLICATE of bug 4621
Product: rsync
Classification: Unclassified
Component: core
3.0.7
x86 Linux
: P5 enhancement
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-24 16:30 UTC by yannick
Modified: 2011-05-24 17:52 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description yannick 2011-05-24 16:30:17 UTC
Command test :
rsync -vvvvvvvr /ftpd/yannick/ /test/abc/def/yaya/lolo/ghi/ss

Return error :
rsync: mkdir "/test/abc/def/yaya/lolo/ghi/ss" failed: No such file or directory (2)
[Receiver] _exit_cleanup(code=11, file=main.c, line=595): entered
rsync error: error in file IO (code 11) at main.c(595) [Receiver=3.0.7]
[Receiver] _exit_cleanup(code=11, file=main.c, line=595): about to call exit(11)
rsync: connection unexpectedly closed (9 bytes received so far) [sender]
[sender] _exit_cleanup(code=12, file=io.c, line=601): entered
rsync error: error in rsync protocol data stream (code 12) at io.c(601) [sender=3.0.7]
[sender] _exit_cleanup(code=12, file=io.c, line=601): about to call exit(12)
Comment 1 Kevin Korb 2011-05-24 16:32:04 UTC
Did/ test/abc/def/yaya/lolo/ghi exist?
Rsync will create the target dir if it doesn't already exist but it will not create the parents of the target dir.

Try mkdir -p.
Comment 2 yannick 2011-05-24 16:39:05 UTC
(In reply to comment #1)
> Did/ test/abc/def/yaya/lolo/ghi exist?
> Rsync will create the target dir if it doesn't already exist but it will not
> create the parents of the target dir.
> 
> Try mkdir -p.


mkdir -p after call rsync? it's ok in local but for rsync machine A to B mkdir is not possible
Comment 3 Matt McCutchen 2011-05-24 17:52:35 UTC
Yannick, "blocker" means that the bug blocks most meaningful use cases of rsync, not that it blocks what you are trying to do with rsync.

The behavior is as currently expected, and we already have an enhancement request for an option to create the ancestors of the destination.

*** This bug has been marked as a duplicate of bug 4621 ***