Bug 8134 - CIFS Not Responding Error On Working System
CIFS Not Responding Error On Working System
Status: RESOLVED FIXED
Product: CifsVFS
Classification: Unclassified
Component: kernel fs
2.6
x64 Linux
: P5 normal
: ---
Assigned To: Steve French
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-13 23:33 UTC by Mike
Modified: 2012-02-13 19:49 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike 2011-05-13 23:33:53 UTC
Recently I lost my hard drive and had to reinstall Debian.  I am now getting these errors in /var/log/syslog and I can't figure out why:
Apr 28 11:57:05 rockenfield kernel: [1479867.192022] CIFS VFS: Server peart has not responded in 300 seconds. Reconnecting...

The weird thing is that there are no problems.  I can view the shares on the remote Windows machine (peart is WinXP 64 SP2) with no problems whatsoever.  Also my Windows machine can see my samba shares as well, so both directions work fine and I'm not sure why these messages are occurring.


Here is my /etc/fstab (samba/cifs mounts only, trimmed to applicable content):
//peart/mp3  /mnt/peart/mp3 cifs defaults,credentials=/etc/samba/smbpass.peart,_netdev 0 0
//peart/software  /mnt/peart/software cifs defaults,credentials=/etc/samba/smbpass.peart,_netdev 0 0
//peart/backup  /mnt/peart/backup cifs defaults,credentials=/etc/samba/smbpass.peart,_netdev 0 0
//peart/dvd  /mnt/peart/dvd cifs defaults,credentials=/etc/samba/smbpass.peart,_netdev 0 0


Here is my /etc/samba/smb.conf:
[global]
   workgroup = HOME_NETWORK
   netbios name = ROCKENFIELD
   server string = %h server - Debian GNU/Linux
   dns proxy = no
   name resolve order = lmhosts host wins bcast
   interfaces = 192.168.123.0/24 eth1
   bind interfaces only = yes
   hosts allow = 192.168.123.
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   panic action = /usr/share/samba/panic-action %d
   security = user
   encrypt passwords = true
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   pam password change = yes
   socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
[homes]
   comment = Home Directories
   browseable = no
   read only = no
   create mask = 0700
   directory mask = 0700
   valid users = %S
[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700
[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no


rockenfield is a Debian box running wheezy/testing (7.0).  The kernel version is 2.6.38-2-amd64.  Samba version is 3.5.8~dfsg-1 (obtained from "dpkg -l | grep samba").  This is just a home network, so I don't have a Domain Controller or anything fancy.  It's just a Debian box and a WinXP box (both 64 bit) and I'm sharing files/directories on each side.  This is a new issue since my Debian re-installation.  It was not a problem before but I can't figure out what's changed.
Comment 1 Jeff Layton 2011-05-14 00:23:55 UTC
I suspect that this kernel patch, already slated for 2.6.39 will fix the problem:

http://git.kernel.org/?p=linux/kernel/git/sfrench/cifs-2.6.git;a=commitdiff;h=fd88ce9313e9f9d3b56eada7fc76a301828baefd

...can you test it and tell us whether it does? If so, then my recommendation would be to push this to stable as well.
Comment 2 Mike 2011-05-14 18:24:12 UTC
I don't really know how to apply patches.  I can see we're changing three .c and .h files, so that tells me I'll have to run make as well.  Can I get some brief instructions on how to make the changes?  Thanks!
Comment 3 Mike 2011-05-18 20:26:38 UTC
One more thing to add...  I honestly think this is a configuration issue on my end.  I find no other matches for this problem when doing a web search.  It's probably something really simple and we'll all kick ourselves.  Anyhow the fact that I'm the only person reporting this tells me it's not a bug, but I filed a bug as requested when I posed the question to the linux-cifs@vger.kernel.org mailing list.
Comment 4 Jeff Layton 2012-02-13 19:49:32 UTC
Is this an issue with more recent kernels? I believe it should now be fixed,
but if it isn't please reopen this bug.