Bug 8133 - strange behavior for the file (whose filename first character is period ) in SMB2 case.
strange behavior for the file (whose filename first character is period ) in ...
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: SMB2
3.6.0pre3
x64 Windows Vista
: P5 critical
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-13 18:04 UTC by Kenichi.N
Modified: 2011-05-23 18:22 UTC (History)
0 users

See Also:


Attachments
git-am fix for 3.6.0 (1.49 KB, patch)
2011-05-20 17:57 UTC, Jeremy Allison
vl: review+
Details
git-am fix for 3.6.0 (1.26 KB, patch)
2011-05-20 17:58 UTC, Jeremy Allison
vl: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kenichi.N 2011-05-13 18:04:57 UTC
I set the smb.conf as
 max protocol = SMB2;

In this case, the I can't move the file whose filename 
first character is period (for example, '.hoge.txt') on
the samba mounted directory to its subdirectory.
Using usual explorer on Windows Vista.

(I know that in the Windows, such files (like '.hoge.txt')
can not be created by using explorer. However, there are 
ways to create such files.)

For example, the samba mounted directory is \\sambaserver.
Then I can't move
 \\sambaserver\directory1\.hoge.txt
 to
 \\sambaserver\directory1\subdirecotry2\.hoge.txt
.

In other case, (for example, move to local directory or use SMB1, 
etc.) I can do such.

I think x64 or Vista is not the reason.

K. Naito
Comment 1 Jeremy Allison 2011-05-19 22:31:04 UTC
I have reproduced, will post a patch for 3.6.0rc1 shortly.

Jeremy.
Comment 2 Jeremy Allison 2011-05-20 17:57:22 UTC
Created attachment 6462 [details]
git-am fix for 3.6.0

This is an optimization, not part of the main fix - but dammit it's such an obvious one that saves an xattr read it'd be a shame not to get it into the code for 3.6.0 final :-).

Jeremy.
Comment 3 Jeremy Allison 2011-05-20 17:58:12 UTC
Created attachment 6463 [details]
git-am fix for 3.6.0

This is the actual fix - ensures SMB2 renames pass the correct attr flags to rename_internal_fsp(). Needs to go into 3.6.0 final.

Jeremy.
Comment 4 Jeremy Allison 2011-05-23 02:48:34 UTC
Karolin please pick both patches for 3.6.0. Thanks !
Jeremy.
Comment 5 Karolin Seeger 2011-05-23 18:22:39 UTC
Pushed to v3-6-test.
Closing out bug report.

Thanks!