Bug 8129 - Application requests printing on Format A5, but prints as A4
Application requests printing on Format A5, but prints as A4
Status: RESOLVED FIXED
Product: Samba 3.5
Classification: Unclassified
Component: Printing
3.5.8
All All
: P5 normal
: ---
Assigned To: Andreas Schneider
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-10 10:03 UTC by Gunter Co
Modified: 2011-08-31 16:06 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gunter Co 2011-05-10 10:03:36 UTC
Samba is being used as a print-spooler in conjunction with CUPS and a bunch  of Postscript printers, fitted with A4 and A5 trays.

After an upgrade from 3.4.8 to 3.5.8 we ran into following problem:
Some printouts from application, intended to print on format A5, are printed out on A4, instead of A5. After reverting back to Version 3.4.8. everything was fine again

Solution:
We're not very deep in the sources, but found something strange, that obviously might be the cause of the error:

samba-3.5.8/source3/printing/nt_printing.c:
  array default_forms[]:
    there have been some new entries defined ("A0" & "A1").

samba-3.5.8/librpc/gen_ndr/spoolss.h:
  The symbols "DMPAPER_*" are referring as and index to the entries in the array default_forms[]. But it seems, that the indices have not been updated correctly to match the (new and shifted) entries in default_forms[]

We deleted the new entries (A0 & A1), recompiled samba, and verified correct functionality again.

Gunter
Comment 1 Andreas Schneider 2011-05-21 07:48:45 UTC
Karolin, could you please revert 73bec197a91a15aa9a69c9a3868ed51bdd3674ea in 3.5.

Thanks!
Comment 2 Andreas Schneider 2011-05-21 08:37:41 UTC
See also https://bugzilla.samba.org/show_bug.cgi?id=7423
Comment 3 Karolin Seeger 2011-05-23 18:18:05 UTC
(In reply to comment #1)
> Karolin, could you please revert 73bec197a91a15aa9a69c9a3868ed51bdd3674ea in
> 3.5.
> 
> Thanks!

Done.
Re-assigning to Andreas.
Comment 4 Andreas Schneider 2011-08-31 16:06:21 UTC
This has been fixed.