Bug 812 - Many PANICS
Many PANICS
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.0
Other Linux
: P1 critical
: none
Assigned To: Jeremy Allison
:
Depends on:
Blocks: 807
  Show dependency treegraph
 
Reported: 2003-11-25 07:25 UTC by Klaus Steinberger
Modified: 2005-08-24 10:19 UTC (History)
1 user (show)

See Also:


Attachments
smb.conf file (1.59 KB, text/plain)
2003-11-25 07:27 UTC, Klaus Steinberger
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Klaus Steinberger 2003-11-25 07:25:40 UTC
We get many PANICS from our samba Fileserver, we even updated to 3.0.1pre3 in
the hope that it solves the problems.

We suspect that at least some of the crashes have to do with filenames not in
UTF8. We currently have many files on disk with non UTF-8 character sets, and
can not completely rewrite them, due to a mixture of Redhat 7.x and Redhat 9 system.

Here are some of the Backtrace's we see:

Nov 25 15:30:44 etprd04 smbd[27313]: [2003/11/25 15:30:44, 0]
lib/fault.c:fault_report(36)                                                   
                Nov 25 15:30:44 etprd04 smbd[27313]:  
===============================================================
Nov 25 15:30:44 etprd04 smbd[27313]: [2003/11/25 15:30:44, 0]
lib/fault.c:fault_report(37)                                                   
                Nov 25 15:30:44 etprd04 smbd[27313]:   INTERNAL ERROR: Signal 11
in pid 27313 (3.0.1pre3-1.9.mll.3)
Nov 25 15:30:44 etprd04 smbd[27313]:   Please read the appendix Bugs of the
Samba HOWTO collection                                                         
  Nov 25 15:30:44 etprd04 smbd[27313]: [2003/11/25 15:30:44, 0]
lib/fault.c:fault_report(39)
Nov 25 15:30:44 etprd04 smbd[27313]:  
===============================================================                
                                       Nov 25 15:30:44 etprd04 smbd[27313]:
[2003/11/25 15:30:44, 0] lib/util.c:smb_panic(1422)
Nov 25 15:30:44 etprd04 smbd[27313]:   PANIC: internal error                   
                                                                             
Nov 25 15:30:44 etprd04 smbd[27313]: [2003/11/25 15:30:44, 0]
lib/util.c:smb_panic(1430)
Nov 25 15:30:44 etprd04 smbd[27313]:   BACKTRACE: 16 stack frames:             
                                                                             
Nov 25 15:30:44 etprd04 smbd[27313]:    #0 smbd(smb_panic+0x11c) [0x81ba48c]
Nov 25 15:30:44 etprd04 smbd[27313]:    #1 smbd [0x81a89f2]                    
                                                                             
Nov 25 15:30:44 etprd04 smbd[27313]:    #2 /lib/tls/libc.so.6 [0x420277b8]
Nov 25 15:30:44 etprd04 smbd[27313]:    #3 /lib/tls/libc.so.6(__libc_free+0x88)
[0x42073908]                                                                 
Nov 25 15:30:44 etprd04 smbd[27313]:    #4 smbd(CloseDir+0x2e) [0x8085e9e]
Nov 25 15:30:44 etprd04 smbd[27313]:    #5 smbd [0x8084719]                    
                                                                             
Nov 25 15:30:44 etprd04 smbd[27313]:    #6 smbd(dptr_close+0x37) [0x80847d7]
Nov 25 15:30:44 etprd04 smbd[27313]:    #7 smbd [0x80ac559]                    
                                                                             
Nov 25 15:30:44 etprd04 smbd[27313]:    #8 smbd(reply_trans2+0x6c7) [0x80b4807]
Nov 25 15:30:44 etprd04 smbd[27313]:    #9 smbd [0x80c7c46]                    
                                                                             
Nov 25 15:30:44 etprd04 smbd[27313]:    #10 smbd [0x80c7e19]
Nov 25 15:30:44 etprd04 smbd[27313]:    #11 smbd(process_smb+0x8f) [0x80c802f] 
                                                                             
Nov 25 15:30:44 etprd04 smbd[27313]:    #12 smbd(smbd_process+0x167) [0x80c8c67]
Nov 25 15:30:44 etprd04 smbd[27313]:    #13 smbd(main+0x4bf) [0x8225a0f]       
                                                                             
Nov 25 15:30:44 etprd04 smbd[27313]:    #14
/lib/tls/libc.so.6(__libc_start_main+0xe4) [0x42015704]
Nov 25 15:30:44 etprd04 smbd[27313]:    #15 smbd(chroot+0x31) [0x8076c31]      
                                                                             
Nov 25 15:30:44 etprd04 smbd[27313]:
Nov 25 15:30:45 etprd04 smbd[27314]: [2003/11/25 15:30:45, 0]
lib/fault.c:fault_report(36)
Nov 25 15:30:45 etprd04 smbd[27314]:  
===============================================================
Nov 25 15:30:45 etprd04 smbd[27314]: [2003/11/25 15:30:45, 0]
lib/fault.c:fault_report(37)
Nov 25 15:30:45 etprd04 smbd[27314]:   INTERNAL ERROR: Signal 11 in pid 27314
(3.0.1pre3-1.9.mll.3)
Nov 25 15:30:45 etprd04 smbd[27314]:   Please read the appendix Bugs of the
Samba HOWTO collection
Nov 25 15:30:45 etprd04 smbd[27314]: [2003/11/25 15:30:45, 0]
lib/fault.c:fault_report(39)
Nov 25 15:30:45 etprd04 smbd[27314]:  
===============================================================
Nov 25 15:30:45 etprd04 smbd[27314]: [2003/11/25 15:30:45, 0]
lib/util.c:smb_panic(1422)
Nov 25 15:30:45 etprd04 smbd[27314]:   PANIC: internal error
Nov 25 15:30:45 etprd04 smbd[27314]: [2003/11/25 15:30:45, 0]
lib/util.c:smb_panic(1430)
Nov 25 15:30:45 etprd04 smbd[27314]:   BACKTRACE: 23 stack frames:
Nov 25 15:30:45 etprd04 smbd[27314]:    #0 smbd(smb_panic+0x11c) [0x81ba48c]
Nov 25 15:30:45 etprd04 smbd[27314]:    #1 smbd [0x81a89f2]
Nov 25 15:30:45 etprd04 smbd[27314]:    #2 /lib/tls/libc.so.6 [0x420277b8]
Nov 25 15:30:45 etprd04 smbd[27314]:    #3 /lib/tls/libc.so.6 [0x42074f9a]
Nov 25 15:30:45 etprd04 smbd[27314]:    #4
/lib/tls/libc.so.6(__libc_realloc+0x106) [0x42073a46]
Nov 25 15:30:45 etprd04 smbd[27314]:    #5 smbd(Realloc+0x80) [0x81b9600]
Nov 25 15:30:45 etprd04 smbd[27314]:    #6 smbd(convert_string_allocate+0x3e7)
[0x81a67f7]
Nov 25 15:30:45 etprd04 smbd[27314]:    #7 smbd(push_ucs2_allocate+0x49) [0x81a7099]
Nov 25 15:30:45 etprd04 smbd[27314]:    #8 smbd(unix_strupper+0x24) [0x81a6964]
Nov 25 15:30:45 etprd04 smbd[27314]:    #9 smbd(strupper_m+0x42) [0x81b3582]
Nov 25 15:30:45 etprd04 smbd[27314]:    #10 smbd [0x80d03da]
Nov 25 15:30:45 etprd04 smbd[27314]:    #11 smbd [0x80d0e42]
Nov 25 15:30:45 etprd04 smbd[27314]:    #12 smbd(mangle_map+0x82) [0x80ced72]
Nov 25 15:30:45 etprd04 smbd[27314]:    #13 smbd [0x80abfa2]
Nov 25 15:30:45 etprd04 smbd[27314]:    #14 smbd [0x80ac80c]
Nov 25 15:30:45 etprd04 smbd[27314]:    #15 smbd(reply_trans2+0x6c7) [0x80b4807]
Nov 25 15:30:45 etprd04 smbd[27314]:    #16 smbd [0x80c7c46]
Nov 25 15:30:45 etprd04 smbd[27314]:    #17 smbd [0x80c7e19]
Nov 25 15:30:45 etprd04 smbd[27314]:    #18 smbd(process_smb+0x8f) [0x80c802f]
Nov 25 15:30:45 etprd04 smbd[27314]:    #19 smbd(smbd_process+0x167) [0x80c8c67]
Nov 25 15:30:45 etprd04 smbd[27314]:    #20 smbd(main+0x4bf) [0x8225a0f]
Nov 25 15:30:45 etprd04 smbd[27314]:    #21
/lib/tls/libc.so.6(__libc_start_main+0xe4) [0x42015704]
Nov 25 15:30:45 etprd04 smbd[27314]:    #22 smbd(chroot+0x31) [0x8076c31]
Nov 25 15:30:45 etprd04 smbd[27314]:
Nov 25 15:31:59 etprd04 smbd[27316]: [2003/11/25 15:31:59, 0]
lib/fault.c:fault_report(36)
Nov 25 15:31:59 etprd04 smbd[27316]:  
===============================================================
Nov 25 15:31:59 etprd04 smbd[27316]: [2003/11/25 15:31:59, 0]
lib/fault.c:fault_report(37)
Nov 25 15:31:59 etprd04 smbd[27316]:   INTERNAL ERROR: Signal 11 in pid 27316
(3.0.1pre3-1.9.mll.3)
Nov 25 15:31:59 etprd04 smbd[27316]:   Please read the appendix Bugs of the
Samba HOWTO collection
Nov 25 15:31:59 etprd04 smbd[27316]: [2003/11/25 15:31:59, 0]
lib/fault.c:fault_report(39)
Nov 25 15:31:59 etprd04 smbd[27316]:  
===============================================================
Nov 25 15:31:59 etprd04 smbd[27316]: [2003/11/25 15:31:59, 0]
lib/util.c:smb_panic(1422)
Nov 25 15:31:59 etprd04 smbd[27316]:   PANIC: internal error
Nov 25 15:31:59 etprd04 smbd[27316]: [2003/11/25 15:31:59, 0]
lib/util.c:smb_panic(1430)
Nov 25 15:31:59 etprd04 smbd[27316]:   BACKTRACE: 15 stack frames:
Nov 25 15:31:59 etprd04 smbd[27316]:    #0 smbd(smb_panic+0x11c) [0x81ba48c]
Nov 25 15:31:59 etprd04 smbd[27316]:    #1 smbd [0x81a89f2]
Nov 25 15:31:59 etprd04 smbd[27316]:    #2 /lib/tls/libc.so.6 [0x420277b8]
Nov 25 15:31:59 etprd04 smbd[27316]:    #3 /lib/tls/libc.so.6 [0x420743c9]
Nov 25 15:31:59 etprd04 smbd[27316]:    #4 /lib/tls/libc.so.6(malloc+0x8d)
[0x4207378d]
Nov 25 15:31:59 etprd04 smbd[27316]:    #5 smbd(Realloc+0xd7) [0x81b9657]
Nov 25 15:31:59 etprd04 smbd[27316]:    #6 smbd [0x80af403]
Nov 25 15:31:59 etprd04 smbd[27316]:    #7 smbd(reply_trans2+0x7d8) [0x80b4918]
Nov 25 15:31:59 etprd04 smbd[27316]:    #8 smbd [0x80c7c46]
Nov 25 15:31:59 etprd04 smbd[27316]:    #9 smbd [0x80c7e19]
Nov 25 15:31:59 etprd04 smbd[27316]:    #10 smbd(process_smb+0x8f) [0x80c802f]
Nov 25 15:31:59 etprd04 smbd[27316]:    #11 smbd(smbd_process+0x167) [0x80c8c67]
Nov 25 15:31:59 etprd04 smbd[27316]:    #12 smbd(main+0x4bf) [0x8225a0f]
Nov 25 15:31:59 etprd04 smbd[27316]:    #13
/lib/tls/libc.so.6(__libc_start_main+0xe4) [0x42015704]
Nov 25 15:31:59 etprd04 smbd[27316]:    #14 smbd(chroot+0x31) [0x8076c31]
Nov 25 15:31:59 etprd04 smbd[27316]:

Sincerly,
Klaus
Comment 1 Klaus Steinberger 2003-11-25 07:27:31 UTC
Created attachment 266 [details]
smb.conf file
Comment 2 Jeremy Allison 2003-12-01 13:32:59 UTC
I've noticed your smb.conf file contains no character set
definitions. Can you please try adding these lines :

unix charset = ISO8859-1
dos charset = CP850

and see if you can reproduce the problem (I'm assuming
your filename are in Western European codepages).

Also, your backtraces look like malloc corruption problems
to me. Is there any chance on the RedHat box you can set the
environment variable :

MALLOC_CHECK=2

before running smbd ? This will help catch malloc curruption
bugs at the cost of some speed whilst running.

Thanks,

Jeremy.

Jeremy.
Comment 3 Klaus Steinberger 2003-12-03 04:45:43 UTC
We converted meanwhile many filenames of our users to UTF8, so the Panics are
now very rare, down to 1 per day. The first thing we had to do was conversion of
all filenames inside roaming profiles, as otherwise our users couldn't login. So
I cannot try to change charset parameters to latin1 and cp850 respectively. 

I did add the MALLOC_CHECK variable to one of our servers. As far as I see
results I will send you the output. Also I will try to setup a testcase on one
of our test system. 

Sincerly,
Klaus
Comment 4 Klaus Steinberger 2003-12-03 08:46:23 UTC
I got meanwhile again a PANIC, but i do not see anything regarding MALLOC_CHECK.
Could it probably be that the redhat initrd script clean up environment
variables during call to daemon? 

Here is the PANIC:

Dec  3 15:15:10 etprd04 smbd[19516]: [2003/12/03 15:15:10, 0]
lib/fault.c:fault_report(36) 
Dec  3 15:15:10 etprd04 smbd[19516]:  
===============================================================
Dec  3 15:15:10 etprd04 smbd[19516]: [2003/12/03 15:15:10, 0]
lib/fault.c:fault_report(37) 
Dec  3 15:15:10 etprd04 smbd[19516]:   INTERNAL ERROR: Signal 11 in pid 19516
(3.0.1pre3-1.9.mll.3) 
Dec  3 15:15:10 etprd04 smbd[19516]:   Please read the appendix Bugs of the
Samba HOWTO collection 
Dec  3 15:15:10 etprd04 smbd[19516]: [2003/12/03 15:15:10, 0]
lib/fault.c:fault_report(39) 
Dec  3 15:15:10 etprd04 smbd[19516]:  
=============================================================== 
Dec  3 15:15:10 etprd04 smbd[19516]: [2003/12/03 15:15:10, 0]
lib/util.c:smb_panic(1422) 
Dec  3 15:15:10 etprd04 smbd[19516]:   PANIC: internal error 
Dec  3 15:15:10 etprd04 smbd[19516]: [2003/12/03 15:15:10, 0]
lib/util.c:smb_panic(1430) 
Dec  3 15:15:10 etprd04 smbd[19516]:   BACKTRACE: 15 stack frames: 
Dec  3 15:15:10 etprd04 smbd[19516]:    #0 smbd(smb_panic+0x11c) [0x81ba48c]
Dec  3 15:15:10 etprd04 smbd[19516]:    #1 smbd [0x81a89f2] 
Dec  3 15:15:10 etprd04 smbd[19516]:    #2 /lib/tls/libc.so.6 [0x420277b8]
Dec  3 15:15:10 etprd04 smbd[19516]:    #3 /lib/tls/libc.so.6 [0x420743c9] 
Dec  3 15:15:10 etprd04 smbd[19516]:    #4 /lib/tls/libc.so.6(malloc+0x8d)
[0x4207378d] 
Dec  3 15:15:10 etprd04 smbd[19516]:    #5 smbd(Realloc+0xd7) [0x81b9657] 
Dec  3 15:15:10 etprd04 smbd[19516]:    #6 smbd [0x80acd41] 
Dec  3 15:15:10 etprd04 smbd[19516]:    #7 smbd(reply_trans2+0x709) [0x80b4849]
Dec  3 15:15:10 etprd04 smbd[19516]:    #8 smbd [0x80c7c46] 
Dec  3 15:15:10 etprd04 smbd[19516]:    #9 smbd [0x80c7e19] 
Dec  3 15:15:10 etprd04 smbd[19516]:    #10 smbd(process_smb+0x8f) [0x80c802f]
Dec  3 15:15:10 etprd04 smbd[19516]:    #11 smbd(smbd_process+0x167) [0x80c8c67] 
Dec  3 15:15:10 etprd04 smbd[19516]:    #12 smbd(main+0x4bf) [0x8225a0f] 
Dec  3 15:15:10 etprd04 smbd[19516]:    #13
/lib/tls/libc.so.6(__libc_start_main+0xe4) [0x42015704] 
Dec  3 15:15:10 etprd04 smbd[19516]:    #14 smbd(chroot+0x31) [0x8076c31]
Dec  3 15:15:10 etprd04 smbd[19516]: 
Comment 5 Jeremy Allison 2003-12-03 14:18:26 UTC
Can you compile smbd with -g so we can get a better 
backtrace ? I can't see exactly where this is dying.
Thanks,
Jeremy.
Comment 6 Nuno Higgs 2004-02-27 03:02:14 UTC
Is there a change for a patch that does not require changing the filenames?
Comment 7 Jeremy Allison 2004-02-27 10:05:13 UTC
Sorry, I didn't update this once I did the work in 3.0.2.
3.0.2 should not panic on these filenames now. It will give
back incorrect filenames instead, but that's what you want,
because that's what you've got on disk :-). It won't panic
now though. Please try upgrading to 3.0.2.
Jeremy.
Comment 8 Nuno Higgs 2004-02-28 13:29:10 UTC
You'r a mate... tkx... will try to upgrade tomorrow for tonight is beer 
night :D
Comment 9 Nuno Higgs 2004-03-01 04:04:00 UTC
Worked like a charm... tkx...
Comment 10 Jeremy Allison 2004-03-01 09:51:07 UTC
Fixed as per customer comment (hurrah ! Definately the right thing for 3.0.2 :-).
Jeremy.
Comment 11 Gerald (Jerry) Carter 2005-08-24 10:19:04 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.