Bug 809 - Samba is crashing a lot, lraving corrupt files on the servers.
Samba is crashing a lot, lraving corrupt files on the servers.
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.0
All Linux
: P1 critical
: none
Assigned To: Gerald (Jerry) Carter
:
: 384 (view as bug list)
Depends on:
Blocks: 807
  Show dependency treegraph
 
Reported: 2003-11-25 03:10 UTC by Richard Allen
Modified: 2005-11-14 09:29 UTC (History)
3 users (show)

See Also:


Attachments
smb.conf (11.27 KB, text/plain)
2003-11-25 05:57 UTC, Richard Allen
no flags Details
Samba Log file for station 10 (50.28 KB, text/plain)
2004-04-27 10:13 UTC, Carlos Peon
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Allen 2003-11-25 03:10:26 UTC
I'm running Fedora Core 1 (Samba 3.0.0-15).  Samba is randomly crashing in my
environment.  Syslog has:

Nov 25 10:22:35 linux smbd[20671]: [2003/11/25 10:22:35, 0]
lib/fault.c:fault_report(36)
Nov 25 10:22:35 linux smbd[20671]:  
===============================================================
Nov 25 10:22:35 linux smbd[20671]: [2003/11/25 10:22:35, 0]
lib/fault.c:fault_report(37)
Nov 25 10:22:35 linux smbd[20671]:   INTERNAL ERROR: Signal 11 in pid 20671
(3.0.0-15)
Nov 25 10:22:35 linux smbd[20671]:   Please read the appendix Bugs of the Samba
HOWTO collection
Nov 25 10:22:35 linux smbd[20671]: [2003/11/25 10:22:35, 0]
lib/fault.c:fault_report(39)
Nov 25 10:22:35 linux smbd[20671]:  
===============================================================
Nov 25 10:22:35 linux smbd[20671]: [2003/11/25 10:22:35, 0]
lib/util.c:smb_panic(1422)
Nov 25 10:22:35 linux smbd[20671]:   PANIC: internal error
Nov 25 10:22:35 linux smbd[20671]: [2003/11/25 10:22:35, 0]
lib/util.c:smb_panic(1429)
Nov 25 10:22:35 linux smbd[20671]:   BACKTRACE: 22 stack frames:
Nov 25 10:22:35 linux smbd[20671]:    #0 smbd(smb_panic+0x110) [0x803430]
Nov 25 10:22:35 linux smbd[20671]:    #1 smbd [0x7ef3e4]
Nov 25 10:22:35 linux smbd[20671]:    #2 /lib/tls/libc.so.6 [0x144a38]
Nov 25 10:22:36 linux smbd[20671]:    #3 /lib/tls/libc.so.6 [0x18daca]
Nov 25 10:22:36 linux smbd[20671]:    #4 /lib/tls/libc.so.6(malloc+0x8d) [0x18ce7d]
Nov 25 10:22:36 linux smbd[20671]:    #5 smbd(Realloc+0xa8) [0x802408]
Nov 25 10:22:37 linux smbd[20671]:    #6 smbd(convert_string_allocate+0x435)
[0x7ecdb5]
Nov 25 10:22:37 linux smbd[20671]:    #7 smbd(unix_strlower+0x44) [0x7ed114]
Nov 25 10:22:37 linux smbd[20671]:    #8 smbd(strlower_m+0x55) [0x7fb705]
Nov 25 10:22:38 linux smbd[20671]:    #9 smbd [0x724eee]
Nov 25 10:22:38 linux smbd[20671]:    #10 smbd(ntlmssp_server_update+0x191)
[0x725631]
Nov 25 10:22:39 linux smbd[20671]:    #11 smbd(auth_ntlmssp_update+0x4b) [0x843fcb]
Nov 25 10:22:39 linux smbd[20671]:    #12 smbd [0x6d0041]
Nov 25 10:22:39 linux smbd[20671]:    #13 smbd [0x6d05a9]
Nov 25 10:22:40 linux smbd[20671]:    #14 smbd(reply_sesssetup_and_X+0xdb5)
[0x6d14b5]
Nov 25 10:22:40 linux smbd[20671]:    #15 smbd [0x6f21bf]
Nov 25 10:22:41 linux smbd[20671]:    #16 smbd [0x6f2463]
Nov 25 10:22:41 linux smbd[20671]:    #17 smbd(process_smb+0xa4) [0x6f26b4]
Nov 25 10:22:42 linux smbd[20671]:    #18 smbd(smbd_process+0x19f) [0x6f340f]
Nov 25 10:22:42 linux smbd[20671]:    #19 smbd(main+0x4fd) [0x876f4d]
Nov 25 10:22:42 linux smbd[20671]:    #20
/lib/tls/libc.so.6(__libc_start_main+0xf0) [0x132750]
Nov 25 10:22:43 linux smbd[20671]:    #21 smbd [0x6982e2]
Nov 25 10:22:43 linux smbd[20671]:


These crashes seem to be leaving corrupt files on my servers.   This is
happening quite frequently also.   Logwatch on the machine tells me:

 --------------------- samba Begin ------------------------

      **Unmatched Entries**
lib/fault.c:fault_report(36)
+=============================================================== : 132 Time(s)
lib/fault.c:fault_report(37)  INTERNAL ERROR: Signal 11 in pid 17719 (3.0.0-15)
+Please read the appendix Bugs of the Samba HOWTO collection : 1 Time(s)

132 crashes in the last 24 hours.
Comment 1 Richard Allen 2003-11-25 03:20:47 UTC
testparam reports no problems, iptables are not configured.
Comment 2 Gerald (Jerry) Carter 2003-11-25 05:29:15 UTC
please attach your smb,conf so I can see your
character settings.  Also please try to reproduce this
against 3.0.1pre3.


Comment 3 Richard Allen 2003-11-25 05:57:15 UTC
Created attachment 265 [details]
smb.conf

This is the smb.conf in question.
Comment 4 Richard Allen 2003-11-25 08:35:16 UTC
I didnt see any Fedora rpm's so I got myself the srpm and built it.  I then
uninstalled (rpm -e) the Red Hat packages (samba-common, samba-client and samba)
and installed the freshly built software.   

[root@linux samba]# more log.smbd
[2003/11/25 16:32:33, 0] smbd/server.c:main(747)
  smbd version 3.0.1pre3 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2003

Now we wait and see what happens.
Comment 5 Richard Allen 2003-11-26 03:52:00 UTC
Well, the verdict is in.  3.0.1pre3 still crashes.   Traceback included:

Nov 26 11:16:43 linux smbd[13736]: [2003/11/26 11:16:43, 0]
lib/fault.c:fault_report(36)
Nov 26 11:16:43 linux smbd[13736]:  
===============================================================
Nov 26 11:16:43 linux smbd[13736]: [2003/11/26 11:16:43, 0]
lib/fault.c:fault_report(37)
Nov 26 11:16:43 linux smbd[13736]:   INTERNAL ERROR: Signal 11 in pid 13736
(3.0.1pre3)
Nov 26 11:16:43 linux smbd[13736]:   Please read the appendix Bugs of the Samba
HOWTO collection
Nov 26 11:16:43 linux smbd[13736]: [2003/11/26 11:16:43, 0]
lib/fault.c:fault_report(39)
Nov 26 11:16:43 linux smbd[13736]:  
===============================================================
Nov 26 11:16:43 linux smbd[13736]: [2003/11/26 11:16:43, 0]
lib/util.c:smb_panic(1400)
Nov 26 11:16:43 linux smbd[13736]:   PANIC: internal error
Nov 26 11:16:43 linux smbd[13736]: [2003/11/26 11:16:43, 0]
lib/util.c:smb_panic(1408)
Nov 26 11:16:43 linux smbd[13736]:   BACKTRACE: 17 stack frames:
Nov 26 11:16:43 linux smbd[13736]:    #0 smbd(smb_panic+0x101) [0x81bc351]
Nov 26 11:16:43 linux smbd[13736]:    #1 smbd [0x81aab97]
Nov 26 11:16:43 linux smbd[13736]:    #2 /lib/tls/libc.so.6 [0x85da38]
Nov 26 11:16:43 linux smbd[13736]:    #3 /lib/tls/libc.so.6 [0x8a6aca]
Nov 26 11:16:43 linux smbd[13736]:    #4 /lib/tls/libc.so.6(malloc+0x8d) [0x8a5e7d]
Nov 26 11:16:44 linux smbd[13736]:    #5 smbd(tdb_store+0xf8) [0x81cfaf8]
Nov 26 11:16:44 linux smbd[13736]:    #6 smbd(claim_connection+0x285) [0x8082785]
Nov 26 11:16:44 linux smbd[13736]:    #7 smbd [0x80cabf1]
Nov 26 11:16:44 linux smbd[13736]:    #8 smbd(make_connection+0x12f) [0x80cbe7f]
Nov 26 11:16:45 linux smbd[13736]:    #9 smbd(reply_tcon_and_X+0x1ac) [0x809c4ec]
Nov 26 11:16:45 linux smbd[13736]:    #10 smbd [0x80c885a]
Nov 26 11:16:45 linux smbd[13736]:    #11 smbd [0x80c8ac0]
Nov 26 11:16:45 linux smbd[13736]:    #12 smbd(process_smb+0x8c) [0x80c8ccc]
Nov 26 11:16:45 linux smbd[13736]:    #13 smbd(smbd_process+0x168) [0x80c9938]
Nov 26 11:16:46 linux smbd[13736]:    #14 smbd(main+0x4bc) [0x82272ac]
Nov 26 11:16:46 linux smbd[13736]:    #15
/lib/tls/libc.so.6(__libc_start_main+0xf0) [0x84b750]
Nov 26 11:16:46 linux smbd[13736]:    #16 smbd(ldap_msgfree+0x79) [0x8076961]
Nov 26 11:16:46 linux smbd[13736]:

Comment 6 Gerald (Jerry) Carter 2003-11-26 05:45:33 UTC
ok.  I'll spend some time trying to reproduce it.
Anytyhing in particular you do to cause the crash?
Comment 7 Richard Allen 2003-11-26 07:57:30 UTC
Not that I can think of.   Most of the people using the server are not very
technical computer users.   If Im not mistaken all they do is store files on the
shares and prehaps open/save/close files there vie the M$ Office suite.
I will try to get a core file so I can run additional debugging and try and
figure out what's going on.
Comment 8 Richard Allen 2003-11-27 05:51:00 UTC
I've been unable to get a core file...  Is there something in Samba's error
handling that prevents core's from beeing generated ?
Comment 9 Gerald (Jerry) Carter 2003-11-27 06:59:28 UTC
set 'panic action = /bin/sleep 99999" and you can attach with gdb.
Or...set "panic action = /usr/bin/X11/xterm -display :0 -e gdb /proc/%d/exe %d"
to pop up an xterm with gdb already attached (this works on linux.  you'll 
have to check the exact syntax for solawris).

And to answer the original question, you have to define DUMP_CORE
when compiling.  The panic action is easier though.
Comment 10 Bastien Nocera 2003-12-09 02:50:27 UTC
This bug has also been filed against RHEL 3's Samba, see the backtrace in the
link below:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=111719
Comment 11 Gerald (Jerry) Carter 2003-12-09 20:16:17 UTC
*** Bug 384 has been marked as a duplicate of this bug. ***
Comment 12 Philip Ross 2003-12-29 12:14:37 UTC
I've had a couple of crashes with Samba 3.0.0-15 on Fedora Core 1 too. The stack
traces don't appear to be related to either of those here. Both crashes occurred
while playing the same MP3 using WinAMP on a Windows XP box. I can't reproduce
the crash at the moment.

[2003/12/29 19:49:07, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2003/12/29 19:49:07, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 1663 (3.0.0-15)
  Please read the appendix Bugs of the Samba HOWTO collection
[2003/12/29 19:49:07, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2003/12/29 19:49:07, 0] lib/util.c:smb_panic(1422)
  PANIC: internal error
[2003/12/29 19:49:07, 0] lib/util.c:smb_panic(1429)
  BACKTRACE: 24 stack frames:
   #0 smbd(smb_panic+0x110) [0xe7e430]
   #1 smbd [0xe6a3e4]
   #2 /lib/tls/libc.so.6 [0x386a38]
   #3 /lib/tls/libc.so.6(__libc_free+0x8b) [0x3ceffb]
   #4 smbd [0xdaf18a]
   #5 smbd(close_policy_hnd+0x108) [0xdf8ed8]
   #6 smbd [0xdaf6cc]
   #7 smbd(_reg_close+0x2e) [0xdafa2e]
   #8 smbd [0xdae600]
   #9 smbd(api_rpcTNP+0x18a) [0xdf80ba]
   #10 smbd(api_pipe_request+0xca) [0xdf7e3a]
   #11 smbd [0xdf0b5f]
   #12 smbd [0xdf0f21]
   #13 smbd [0xdf1416]
   #14 smbd(write_to_pipe+0x127) [0xdf1347]
   #15 smbd [0xd29efa]
   #16 smbd(reply_trans+0x53b) [0xd2a8ab]
   #17 smbd [0xd6d1bf]
   #18 smbd [0xd6d463]
   #19 smbd(process_smb+0xa4) [0xd6d6b4]
   #20 smbd(smbd_process+0x19f) [0xd6e40f]
   #21 smbd(main+0x4fd) [0xef1f4d]
   #22 /lib/tls/libc.so.6(__libc_start_main+0xf0) [0x374750]
   #23 smbd [0xd132e2]



[2003/12/29 19:51:33, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2003/12/29 19:51:33, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 1867 (3.0.0-15)
  Please read the appendix Bugs of the Samba HOWTO collection
[2003/12/29 19:51:33, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2003/12/29 19:51:33, 0] lib/util.c:smb_panic(1422)
  PANIC: internal error
[2003/12/29 19:51:33, 0] lib/util.c:smb_panic(1429)
  BACKTRACE: 23 stack frames:
   #0 smbd(smb_panic+0x110) [0xe7e430]
   #1 smbd [0xe6a3e4]
   #2 /lib/tls/libc.so.6 [0x386a38]
   #3 /lib/tls/libc.so.6 [0x3cfaca]
   #4 /lib/tls/libc.so.6(malloc+0x8d) [0x3cee7d]
   #5 smbd(Realloc+0xa8) [0xe7d408]
   #6 smbd(convert_string_allocate+0x435) [0xe67db5]
   #7 smbd(push_ucs2_allocate+0x56) [0xe68726]
   #8 smbd(unix_strupper+0x2c) [0xe67f0c]
   #9 smbd(strupper_m+0x55) [0xe76785]
   #10 smbd [0xd77396]
   #11 smbd [0xd77f02]
   #12 smbd(mangle_map+0x79) [0xd75af9]
   #13 smbd [0xd4e02c]
   #14 smbd [0xd4efdb]
   #15 smbd(reply_trans2+0x665) [0xd575a5]
   #16 smbd [0xd6d1bf]
   #17 smbd [0xd6d463]
   #18 smbd(process_smb+0xa4) [0xd6d6b4]
   #19 smbd(smbd_process+0x19f) [0xd6e40f]
   #20 smbd(main+0x4fd) [0xef1f4d]
   #21 /lib/tls/libc.so.6(__libc_start_main+0xf0) [0x374750]
   #22 smbd [0xd132e2]
Comment 13 Philip Ross 2003-12-29 12:55:08 UTC
I'm still seeing the occasional crash while playing mp3s from a Samba share. I'm
seeing more of the first two stack traces I reported, plus this one below.

[2003/12/29 20:43:26, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 2198 (3.0.0-15)
  Please read the appendix Bugs of the Samba HOWTO collection
[2003/12/29 20:43:26, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2003/12/29 20:43:26, 0] lib/util.c:smb_panic(1422)
  PANIC: internal error
[2003/12/29 20:43:26, 0] lib/util.c:smb_panic(1429)
  BACKTRACE: 17 stack frames:
   #0 smbd(smb_panic+0x110) [0xe7e430]
   #1 smbd [0xe6a3e4]
   #2 /lib/tls/libc.so.6 [0x386a38]
   #3 /lib/tls/libc.so.6 [0x3cfaca]
   #4 /lib/tls/libc.so.6(malloc+0x8d) [0x3cee7d]
   #5 smbd(tdb_store+0x111) [0xe93dd1]
   #6 smbd(claim_connection+0x2c5) [0xd217c5]
   #7 smbd [0xd6f738]
   #8 smbd(make_connection+0x16a) [0xd70b4a]
   #9 smbd(reply_tcon_and_X+0x1d9) [0xd3d339]
   #10 smbd [0xd6d1bf]
   #11 smbd [0xd6d463]
   #12 smbd(process_smb+0xa4) [0xd6d6b4]
   #13 smbd(smbd_process+0x19f) [0xd6e40f]
   #14 smbd(main+0x4fd) [0xef1f4d]
   #15 /lib/tls/libc.so.6(__libc_start_main+0xf0) [0x374750]
   #16 smbd [0xd132e2]

On closer inspection, the second stack trace I reported seems similar to the
first reported by Richard Allen. The third stack trace (above) I reported seems
similar to the second reported by Richard.
Comment 14 cmarco 2004-01-26 12:13:49 UTC
I just tested 3.0.2rc1from Fedora development tree, result below. This is smal
network with few clients (~15) where Samba provides database files for dos and
windows applications (*.dbf) with high load in peak. This server has been
running flawlessly for years on Samba 2.2 or earlier.

[2004/01/26 12:02:30, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 19144 (3.0.0-15)
  Please read the appendix Bugs of the Samba HOWTO collection
[2004/01/26 12:02:30, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2004/01/26 12:02:30, 0] lib/util.c:smb_panic(1422)
  PANIC: internal error
[2004/01/26 12:02:30, 0] lib/util.c:smb_panic(1429)
  BACKTRACE: 23 stack frames:
   #0 smbd(smb_panic+0x110) [0x7b3430]
   #1 smbd [0x79f3e4]
   #2 /lib/tls/libc.so.6 [0xba7a58]
   #3 /lib/tls/libc.so.6 [0xbf0aea]
   #4 /lib/tls/libc.so.6(malloc+0x8d) [0xbefe9d]
   #5 smbd(Realloc+0xa8) [0x7b2408]
   #6 smbd(convert_string_allocate+0x435) [0x79cdb5]
   #7 smbd(push_ucs2_allocate+0x56) [0x79d726]
   #8 smbd(unix_strupper+0x2c) [0x79cf0c]
   #9 smbd(strupper_m+0x55) [0x7ab785]
   #10 smbd [0x6ac396]
   #11 smbd [0x6acf02]
   #12 smbd(mangle_map+0x79) [0x6aaaf9]
   #13 smbd [0x659924]
   #14 smbd(get_dir_entry+0x51e) [0x659e6e]
   #15 smbd(reply_search+0x3b1) [0x673a51]
   #16 smbd [0x6a21bf]
   #17 smbd [0x6a2463]
   #18 smbd(process_smb+0xa4) [0x6a26b4]
   #19 smbd(smbd_process+0x19f) [0x6a340f]
   #20 smbd(main+0x4fd) [0x826f4d]
   #21 /lib/tls/libc.so.6(__libc_start_main+0xf0) [0xb95770]
   #22 smbd [0x6482e2]


[2004/01/26 17:24:38, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 20681 (3.0.2rc1-1rc1)
  Please read the appendix Bugs of the Samba HOWTO collection
[2004/01/26 17:24:38, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2004/01/26 17:24:38, 0] lib/util.c:smb_panic(1422)
  PANIC: internal error
[2004/01/26 17:24:38, 0] lib/util.c:smb_panic(1430)
  BACKTRACE: 18 stack frames:
   #0 smbd(smb_panic+0x110) [0xb14c10]
   #1 smbd [0xb00774]
   #2 /lib/tls/libc.so.6 [0x35da58]
   #3 /lib/tls/libc.so.6 [0x3a6aea]
   #4 /lib/tls/libc.so.6(malloc+0x8d) [0x3a5e9d]
   #5 /lib/tls/libc.so.6(opendir+0x98) [0x3d8cb8]
   #6 smbd(vfswrap_opendir+0x1f) [0x9f361f]
   #7 smbd(OpenDir+0x34) [0x9b49a4]
   #8 smbd [0x9b37b5]
   #9 smbd(dptr_create+0x2d) [0x9b393d]
   #10 smbd(reply_search+0x249) [0x9ce2f9]
   #11 smbd [0x9fdbaf]
   #12 smbd [0x9fde53]
   #13 smbd(process_smb+0xa4) [0x9fe0a4]
   #14 smbd(smbd_process+0x19f) [0x9fee2f]
   #15 smbd(main+0x4fd) [0xb8ba9d]
   #16 /lib/tls/libc.so.6(__libc_start_main+0xf0) [0x34b770]
   #17 smbd [0x9a2b02]
Comment 15 Gerald (Jerry) Carter 2004-01-26 14:25:17 UTC
all of these reports appear to be centered around 
character conversions.  Have each of you defined the
unix character set and then made sure that all 
filenames/directories are in that set?  The default 
'unix charset' in 3.0 is UTF-8.

Comment 16 Philip Ross 2004-01-26 15:22:00 UTC
I am running with the default UTF-8 unix charset and was getting quite a few of
these crashes. At the time of the crashes, I had several files in shares that
had invalid UTF-8 sequences in their names. I have since fixed all the broken
file names and haven't had a crash since.
Comment 17 Gerald (Jerry) Carter 2004-03-03 08:14:57 UTC
A workaround is in place in 3.0.2a.
Comment 18 Carlos Peon 2004-04-27 10:09:57 UTC
I'm running Red Hat 9.0 with Samba 3.0.2.a and I have the same problem.

I can reproduce the problem in a workstation: When the users (named user10) log 
on (windows XP Prof), It run correctly the logon script and aplies the policy 
setting via ntconfig.pol and load their desktop from a network directory. After 
few seconds, it loses the connection and their desktop disapear levaing only 
the Icon for My computer and the recycle bin.

In the message file I can see 4 or 5 times the same message, and in another 
terminal, I can see with ps -ef the process nmbd -D with owner user10 and PID 
1000 (p.e) that disapears and a new process nmbd -D with owner user10 and PID 
1001 is created, and then disaperar the process 1001 and is created the 
1002, ... after 4 or 5 times, I can reload the desktop and the user can work 
correctly.

I attach the log file for that workstation.

In the /var/log/message file:

Thanks.

Carlos.

Apr 27 18:09:21 e300001ls smbd[12448]: [2004/04/27 18:09:21, 0] 
lib/fault.c:fault_report(36)
Apr 27 18:09:21 e300001ls smbd[12448]:   
===============================================================
Apr 27 18:09:21 e300001ls smbd[12448]: [2004/04/27 18:09:21, 0] 
lib/fault.c:fault_report(37)
Apr 27 18:09:21 e300001ls smbd[12448]:   INTERNAL ERROR: Signal 11 in pid 12448 
(3.0.2a)
Apr 27 18:09:21 e300001ls smbd[12448]:   Please read the appendix Bugs of the 
Samba HOWTO collection
Apr 27 18:09:21 e300001ls smbd[12448]: [2004/04/27 18:09:21, 0] 
lib/fault.c:fault_report(39)
Apr 27 18:09:21 e300001ls smbd[12448]:   
===============================================================
Apr 27 18:09:21 e300001ls smbd[12448]: [2004/04/27 18:09:21, 0] 
lib/util.c:smb_panic(1400)
Apr 27 18:09:21 e300001ls smbd[12448]:   PANIC: internal error
Apr 27 18:09:21 e300001ls smbd[12448]: [2004/04/27 18:09:21, 0] 
lib/util.c:smb_panic(1408)
Apr 27 18:09:21 e300001ls smbd[12448]:   BACKTRACE: 23 stack frames:
Apr 27 18:09:21 e300001ls smbd[12448]:    #0 smbd(smb_panic+0x11c) [0x81c3c3c]
Apr 27 18:09:21 e300001ls smbd[12448]:    #1 smbd [0x81b2372]
Apr 27 18:09:21 e300001ls smbd[12448]:    #2 /lib/tls/libc.so.6 [0x420275c8]
Apr 27 18:09:21 e300001ls smbd[12448]:    #3 smbd(print_queue_status+0x156) 
[0x81e1546]
Apr 27 18:09:21 e300001ls smbd[12448]:    #4 smbd [0x81222fa]
Apr 27 18:09:21 e300001ls smbd[12448]:    #5 smbd(_spoolss_rfnpcnex+0x16a) 
[0x81225aa]
Apr 27 18:09:21 e300001ls smbd[12448]:    #6 smbd [0x8116dde]
Apr 27 18:09:21 e300001ls smbd[12448]:    #7 smbd(api_rpcTNP+0x159) [0x814b109]
Apr 27 18:09:22 e300001ls smbd[12448]:    #8 smbd(api_pipe_request+0xaf) 
[0x814aecf]
Apr 27 18:09:22 e300001ls smbd[12448]:    #9 smbd [0x81445c6]
Apr 27 18:09:22 e300001ls smbd[12448]:    #10 smbd [0x8144919]
Apr 27 18:09:22 e300001ls smbd[12448]:    #11 smbd [0x8144b5b]
Apr 27 18:09:22 e300001ls smbd[12448]:    #12 smbd [0x8144d5c]
Apr 27 18:09:22 e300001ls smbd[12448]:    #13 smbd(write_to_pipe+0xf2) 
[0x8144cb2]
Apr 27 18:09:22 e300001ls smbd[12448]:    #14 smbd [0x8089cde]
Apr 27 18:09:22 e300001ls smbd[12448]:    #15 smbd(reply_trans+0x54b) 
[0x808a6ab]
Apr 27 18:09:22 e300001ls smbd[12448]:    #16 smbd [0x80c8466]
Apr 27 18:09:22 e300001ls smbd[12448]:    #17 smbd [0x80c8639]
Apr 27 18:09:22 e300001ls smbd[12448]:    #18 smbd(process_smb+0x8f) [0x80c884f]
Apr 27 18:09:22 e300001ls smbd[12448]:    #19 smbd(smbd_process+0x167) 
[0x80c9497]
Apr 27 18:09:22 e300001ls smbd[12448]:    #20 smbd(main+0x4bf) [0x822fc1f]
Apr 27 18:09:22 e300001ls smbd[12448]:    #21 /lib/tls/libc.so.6
(__libc_start_main+0xe4) [0x42015574]
Apr 27 18:09:22 e300001ls smbd[12448]:    #22 smbd(ldap_msgfree+0x8d) 
[0x8076f21]
Apr 27 18:09:22 e300001ls smbd[12448]:
Comment 19 Carlos Peon 2004-04-27 10:13:11 UTC
Created attachment 477 [details]
Samba Log file for station 10

Samba 3.0.2.a crashes too
Comment 20 Gerald (Jerry) Carter 2004-04-27 12:12:39 UTC
please don't add comments to closed bugs.  Open a new one.
However, you report is a duplicate of bug 1147 from what it 
looks like. 
Comment 21 Gerald (Jerry) Carter 2005-08-24 10:18:59 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 22 Gerald (Jerry) Carter 2005-11-14 09:29:31 UTC
database cleanup