Bug 8073 - Regress: 3.0.8 cannot compile on freebsd
Regress: 3.0.8 cannot compile on freebsd
Status: RESOLVED DUPLICATE of bug 8053
Product: rsync
Classification: Unclassified
Component: core
3.0.8
x86 FreeBSD
: P5 regression
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-09 23:13 UTC by grarpamp
Modified: 2011-04-10 22:15 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description grarpamp 2011-04-09 23:13:47 UTC
platform: i386
os: FreeBSD 4.11-STABLE
gcc: 2.95.4
why: This is a compile failure regression against 3.0.7.

from 3.0.8 (fails):
gcc -I. -I. -g -O2 -DHAVE_CONFIG_H -Wall -W -I./popt  -c flist.c -o flist.o
flist.c: In function `send_directory':
flist.c:1653: syntax error before `unsigned'
flist.c:1654: `name_len' undeclared (first use in this function)
flist.c:1654: (Each undeclared identifier is reported only once
flist.c:1654: for each function it appears in.)


Other notes:

from 3.0.8 (using flist.c from 3.0.7 for convenient reporting of other warnings herein):
gcc -I. -I. -g -O2 -DHAVE_CONFIG_H -Wall -W -I./popt  -c rsync.c -o rsync.o
rsync.c: In function `set_file_attrs':
rsync.c:378: warning: unused parameter `fnamecmp'
gcc -I. -I. -g -O2 -DHAVE_CONFIG_H -Wall -W -I./popt  -c generator.c -o generator.o
generator.c: In function `delete_item':
generator.c:216: warning: `desc' might be used uninitialized in this function
generator.c: In function `unchanged_attrs':
generator.c:622: warning: unused parameter `fname'
generator.c: In function `itemize':
generator.c:665: warning: unused parameter `fnamecmp'
generator.c: In function `try_dests_non':
generator.c:1112: warning: `type' might be used uninitialized in this function
gcc -I. -I. -g -O2 -DHAVE_CONFIG_H -Wall -W -I./popt  -c sender.c -o sender.o
sender.c: In function `write_ndx_and_attrs':
sender.c:143: warning: unused parameter `fname'
sender.c:143: warning: unused parameter `file'
gcc -I. -I. -g -O2 -DHAVE_CONFIG_H -Wall -W -I./popt  -c io.c -o io.o
io.c: In function `mplex_write':
io.c:470: warning: unused parameter `convert'

from 3.0.7 (works):
gcc -I. -I. -g -O2 -DHAVE_CONFIG_H -Wall -W -I./popt  -c rsync.c -o rsync.o
rsync.c: In function `set_file_attrs':
rsync.c:380: warning: unused parameter `fnamecmp'
gcc -I. -I. -g -O2 -DHAVE_CONFIG_H -Wall -W -I./popt  -c generator.c -o generator.o
generator.c: In function `delete_item':
generator.c:225: warning: `desc' might be used uninitialized in this function
generator.c: In function `unchanged_attrs':
generator.c:585: warning: unused parameter `fname'
generator.c: In function `itemize':
generator.c:628: warning: unused parameter `fnamecmp'
generator.c: In function `try_dests_non':
generator.c:1072: warning: `type' might be used uninitialized in this function
gcc -I. -I. -g -O2 -DHAVE_CONFIG_H -Wall -W -I./popt  -c sender.c -o sender.o
sender.c: In function `write_ndx_and_attrs':
sender.c:143: warning: unused parameter `fname'
sender.c:143: warning: unused parameter `file'
gcc -I. -I. -g -O2 -DHAVE_CONFIG_H -Wall -W -I./popt  -c io.c -o io.o
io.c: In function `mplex_write':
io.c:470: warning: unused parameter `convert'

from 3.0.8 (on freebsd 8.2, gcc 4.2.1):
Works great :)
Comment 1 Wayne Davison 2011-04-10 22:15:35 UTC
See the patch on bug 8053.

*** This bug has been marked as a duplicate of bug 8053 ***