Bug 8062 - Winbind crashing
Winbind crashing
Status: RESOLVED DUPLICATE of bug 7636
Product: Samba 3.4
Classification: Unclassified
Component: Winbind
3.4.7
All All
: P5 normal
: ---
Assigned To: Michael Adam
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-05 19:55 UTC by Chuck Short
Modified: 2011-04-05 20:03 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chuck Short 2011-04-05 19:55:02 UTC
Hi,

We recently received a report that winbind is crashing. The bug report can be found at:

https://bugs.launchpad.net/ubuntu/+source/samba/+bug/736757

I have attached the gdb session below:

Same problem happen to me
ubuntu version: 10.04.2 x86_64
winbind version: 2:3.4.7~dfsg-1ubuntu3.5
And have the similar thread debugging message:

[Thread debugging using libthread_db enabled]
0x00007fb594f32f7e in waitpid () from /lib/libc.so.6
#0 0x00007fb594f32f7e in waitpid () from /lib/libc.so.6
#1 0x00007fb594eca7e9 in ?? () from /lib/libc.so.6
#2 0x00007fb597373264 in smb_panic (why=<value optimized out>)
    at lib/util.c:1486
#3 0x00007fb59736284d in fault_report (sig=11) at lib/fault.c:52
#4 sig_fault (sig=11) at lib/fault.c:75
#5 <signal handler called>
#6 rpc_pipe_np_smb_conn (p=0x0) at rpc_client/rpc_transport_np.c:402
#7 0x00007fb59744e048 in rpccli_set_timeout (rpc_cli=0x0, timeout=35000)
    at rpc_client/cli_pipe.c:2956
#8 0x00007fb5972e87a1 in winbindd_lookup_sids (mem_ctx=0x7fb597fb2b50,
    domain=<value optimized out>, num_sids=<value optimized out>,
    sids=<value optimized out>, domains=0x7fff2af6f1c0, names=0x7fff2af6f1d0,
    types=0x7fff2af6f1c8) at winbindd/winbindd_rpc.c:1221
#9 0x00007fb5972eb092 in lookup_groupmem (domain=0x7fb598041950,
    mem_ctx=0x7fb597fe8950, group_sid=0x7fb598084a90,
    num_names=0x7fff2af6f50c, sid_mem=<value optimized out>,
    names=<value optimized out>, name_types=0x7fff2af6f4d8)
    at winbindd/winbindd_ads.c:1124
#10 0x00007fb5972d2503 in lookup_groupmem (domain=<value optimized out>,
    mem_ctx=<value optimized out>, group_sid=<value optimized out>,
    num_names=0x7fff2af6f50c, sid_mem=0x7fff2af6f4c8, names=0x7fff2af6f4d0,
    name_types=0x7fff2af6f4d8) at winbindd/winbindd_cache.c:2211
#11 0x00007fb5972c55e7 in expand_groups (domain=0x7fb598041950,
    state=<value optimized out>, group_sid=<value optimized out>,
    group_name_type=SID_NAME_DOM_GRP, num_gr_mem=<value optimized out>,
    gr_mem=<value optimized out>, gr_mem_len=0x7fff2af6f898)
    at winbindd/winbindd_group.c:468
#12 fill_grent_mem (domain=0x7fb598041950, state=<value optimized out>,
    group_sid=<value optimized out>, group_name_type=SID_NAME_DOM_GRP,
    num_gr_mem=<value optimized out>, gr_mem=<value optimized out>,
    gr_mem_len=0x7fff2af6f898) at winbindd/winbindd_group.c:604
#13 0x00007fb5972c6a9f in getgrsid_sid2gid_recv (private_data=0x7fb597fd0200,
    success=<value optimized out>, gid=11610) at winbindd/winbindd_group.c:866
#14 0x00007fb5972bfba0 in process_loop (argc=<value optimized out>,
    argv=<value optimized out>, envp=<value optimized out>)
    at winbindd/winbindd.c:1115
#15 main (argc=<value optimized out>, argv=<value optimized out>,
    envp=<value optimized out>) at winbindd/winbindd.c:1440
A debugging session is active.

If you have any questions please let me know.

Regards
chuck
Comment 1 Guenther Deschner 2011-04-05 20:03:12 UTC

*** This bug has been marked as a duplicate of bug 7636 ***