Bug 8057 - -x negates --force
-x negates --force
Status: RESOLVED DUPLICATE of bug 7953
Product: rsync
Classification: Unclassified
Component: core
3.0.7
All All
: P5 normal
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-04 16:51 UTC by ED Fochler
Modified: 2011-04-04 18:24 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ED Fochler 2011-04-04 16:51:34 UTC
more specifically, -x inhibits --force from recursively descending a directory to delete when it is being replaced by a non-directory.  2.6.9 and 3.0.7 on all platforms I've tested exhibit the same behavior. Mac, linux, OpenBSD. The following commands produce the error:

rm -rf src dest                                                                 
                                                                                
mkdir src src/sub1 src/sub1/sub1a src/sub2 src/sub2/sub2a                       
rsync -ax src/ dest/                                                            
                                                                                
rm -Rf src/sub2                                                                 
ln -s sub1 src/sub2                                                             
rsync  --force -ax src/ dest/
Comment 1 Wayne Davison 2011-04-04 16:58:29 UTC

*** This bug has been marked as a duplicate of bug 7953 ***
Comment 2 ED Fochler 2011-04-04 18:24:51 UTC
(In reply to comment #1)
> 
> *** This bug has been marked as a duplicate of bug 7953 ***

Wow.  You are correct sir.  This is fixed in 3.0.8.  Shame on me.

     Thank you very much.