Bug 8043 - the smbpasswd path has a typo (samaba, instead of samba) in the smb.conf file.
the smbpasswd path has a typo (samaba, instead of samba) in the smb.conf file.
Status: RESOLVED INVALID
Product: Samba 3.6
Classification: Unclassified
Component: User & Group Accounts
unspecified
All All
: P5 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-27 18:39 UTC by rmchecchi
Modified: 2011-03-28 09:10 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rmchecchi 2011-03-27 18:39:15 UTC
I installed samba server as part of the Ubuntu 10.10 distro.  Couldn't make it work.  The samba log for the connection would display the error:

smbd/map_username.c:140(map_username) can't open username map /etc/samaba/smbusers.  Error No such file or directory.

The path is misspelled in the default smb.conf file.  Fixing the path fixes samba.
Comment 1 Jelmer Vernooij 2011-03-28 09:10:41 UTC
Did you perhaps still have an old smb.conf file present when you installed Samba ? The default smb.conf file doesn't seem to set the username map at all.

Since this is a distribution-specific (not upstream) issue, please open a bug on Launchpad if you can reproduce it on a clean 10.10 install. Thanks.