Bug 7977 - root permission problem
root permission problem
Status: CLOSED INVALID
Product: ccache
Classification: Unclassified
Component: ccache
3.1.3
x64 Linux
: P3 normal
: ---
Assigned To: Joel Rosdahl
Joel Rosdahl
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-28 13:51 UTC by Don Cohen
Modified: 2011-09-25 17:52 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Don Cohen 2011-02-28 13:51:01 UTC
This originated with clisp configure.
I first did the configure as root, which worked.
I then tried as a non-root user and this failed.
The error was
  ccache: failed to create /var/cache/ccache/tmp (Permission denied) 
Before this I was not even aware that ccache existed.
Comment 1 Joel Rosdahl 2011-02-28 14:42:58 UTC
ccache doesn't write to /var/ccache/ccache without specific configuration, which implies you are not running ccache with default values. And this means that if you haven't configured ccache, then the distribution or operating system you use probably have installed and enabled ccache for you.

So, my guess is that you should send the bug report to your operating system vendor.
Comment 2 Joel Rosdahl 2011-03-27 19:12:33 UTC
Closing - not a ccache bug.