Bug 7942 - inotify can somehow cause endless loops in with select()
inotify can somehow cause endless loops in with select()
Status: RESOLVED FIXED
Product: Samba 3.5
Classification: Unclassified
Component: File services
3.5.6
Other Linux
: P3 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-31 11:04 UTC by Stefan Metzmacher
Modified: 2011-02-05 11:50 UTC (History)
0 users

See Also:


Attachments
Backport Patches for v3-5-test (2.76 KB, patch)
2011-01-31 11:06 UTC, Stefan Metzmacher
no flags Details
Backport Patches for v3-5-test (2.76 KB, patch)
2011-01-31 11:14 UTC, Stefan Metzmacher
vl: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Metzmacher 2011-01-31 11:04:29 UTC
inotify can somehow cause endless loops in with select()
Comment 1 Stefan Metzmacher 2011-01-31 11:06:25 UTC
Created attachment 6235 [details]
Backport Patches for v3-5-test

This patches will doesn't prevent the root cause of the problem,
but they should prevent a 100% CPU loop.
Comment 2 Stefan Metzmacher 2011-01-31 11:08:33 UTC
Comment on attachment 6235 [details]
Backport Patches for v3-5-test

doesn't compile, I'll upload a new one soon
Comment 3 Stefan Metzmacher 2011-01-31 11:14:57 UTC
Created attachment 6236 [details]
Backport Patches for v3-5-test

DLIST_DEMOTE() was changed in master...

This compiles for me now.
Comment 4 Karolin Seeger 2011-02-05 11:50:07 UTC
Pushed to v3-5-test.
Closing out bug report.

Thanks!