Bug 789 - Recycle Module Broken (not solved in 3.0.0)
Recycle Module Broken (not solved in 3.0.0)
Product: Samba 3.0
Classification: Unclassified
Component: File Services
Other Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Depends on:
Blocks: 807
  Show dependency treegraph
Reported: 2003-11-18 05:08 UTC by Rudolf Kollien
Modified: 2005-08-24 10:28 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Rudolf Kollien 2003-11-18 05:08:04 UTC
Seems as Bug #210 is still not solved in 3.0.0
Tried the recycle vfs module with different parameters. But all params seems to
be ignored. The conf for the share is like
   path = /u/samba/pc/kolli
   valid users = kolli root
   public = no
   writeable = yes
   printable = no
   nt acl support = yes
   recycle: repository=.Papierkorb
   recycle: keeptree = yes
   recycle: versions = yes
   browseable = yes
   guest ok = no

Tried to set all param in on line like "vfs objects = recycle recycle: keeptree
= yes..." Nothing changed. Tried "True" and "1" instead of "yes", didn't use
blanks between ":" and between "=". But noting changed. Debuged with level 15 to
see the vfs debug messages. But all params are reported as default like:

[2003/11/18 13:44:35, 10] modules/vfs_recycle.c:recycle_repository(74)
  recycle: repository = .recycle

Deleted files allways went to ".recycle" and the directory tree is not kept.
Tried to only use one parameter (repository). But no effect. Seems the loadparm
gets wrong or don't pass the parameter to the vfs module.
Comment 1 Rudolf Kollien 2003-11-18 05:11:33 UTC
Sorry, by copy'n'paste one of the smb.conf params went away. The blank line
should sound "vfs objects = recycle". I DON'T miss it in the conf. The current
defs are:

   path = /u/samba/pc/kolli
   valid users = kolli root
   public = no
   writeable = yes
   printable = no
   nt acl support = yes
   vfs objects = recycle
   recycle: repository=.Papierkorb
   browseable = yes
   guest ok = no

Comment 2 Rudolf Kollien 2003-11-18 05:16:06 UTC
Bug still lives in 3.0.1pre3.
Comment 3 Gerald (Jerry) Carter 2004-01-05 09:35:49 UTC
adding this to me list
Comment 4 Simon Perry 2004-01-08 18:49:48 UTC
I have the recycle module working ok with stable 3.0.1, however I have found
that the ".recycle" directory is crated with permissions that are only writable
by the user that first deletes a file and forces the creation of the ".recycle"

Should this be lodged as a separate bug, or is it ok to leave details here?

Config used:

        browseable = yes
        public = no
        writable = yes
        force create mode = 0660
        force directory mode = 2770
        vfs objects = recycle
        recycle:keeptree = 1
        recycle:exclude = *.ldb *.tmp *.temp *.o *.obj ~$*
        copy = group_template
        path = /var/test-share
        valid users = @sys

Even with the "force mode" options directory is created as follows:

$ ls -lasi /var/test-share/
total 2
2190346    1 drwxrwsr-x    3 scperry  sys            72 Jan  9 13:38 .
      4    1 drwxr-xr-x   27 root     root          712 Jan  9 10:49 ..
1842336    1 drwx--S---    2 scperry  sys            96 Jan  9 13:38 .recycle
Comment 5 Gerald (Jerry) Carter 2004-03-08 09:46:08 UTC
I'm marking this as fixed since it is ok in 3.0.1.
There's another bug report (bug 1040) that covers the
permissions on newly created directories.
Comment 6 Rudolf Kollien 2004-03-08 10:01:15 UTC
Sorry, but the bug with the not supplied params still live in 3.0.2

Seems to me, that everyone uses the defaults and get happy with. 3.0.2 still do
not deliver params to the vfs object "recycle". Tried every kind of parameter
format (seperate lines, one line, spaces between keywords). No effect.
Comment 7 Gerald (Jerry) Carter 2004-03-08 11:28:52 UTC

I copied you original confi options and it works fine.
I cannot reproduce any obvious errors.  The repository 
directory is created as expected, the directory tree 
is maintained.

Please provide a level 10 debug log of the error you 
are seeing.
Comment 8 Rudolf Kollien 2004-03-08 15:06:14 UTC
Mea culpa! Sorry. Don't know where i got the faulty module. Sorry agein. Run's
as you described. 

I didn't get the "exclude" parameters to work as expected. But may be a wrong
config. Didn't investigated now.

Thank's for your patience.
Comment 9 Gerald (Jerry) Carter 2004-03-09 06:38:36 UTC
probably old recycle module.  closing again.
Comment 10 Gerald (Jerry) Carter 2005-08-24 10:28:05 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.