Bug 785 - configure in samba-3.0.0 ignores LDFLAGS environment variable -- was bug 570
configure in samba-3.0.0 ignores LDFLAGS environment variable -- was bug 570
Status: RESOLVED DUPLICATE of bug 570
Product: Samba 3.0
Classification: Unclassified
Component: Config Files
3.0.0
All Solaris
: P3 normal
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-17 07:06 UTC by Eric Boehm
Modified: 2005-11-14 09:27 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Boehm 2003-11-17 07:06:52 UTC
Bug 570 is still not fixed. I sent email to jerry@samba.org and tpot@samba.org
because I could not find a way to reopen the bug.


The bug still isn't fixed and I don't see a way in bugzilla to reopen
it. 

The LDFLAGS aren't set properly when checking conversion

From my config.log

configure:19755: cc -o conftest -xarch=v9a -D__EXTENSIONS__ -I/usr/local/include
-I/usr/local/openldap/include -I/usr/local/sasl/include
-I/usr/local/kerberos/include -I/usr/local/BerkeleyDB.4.1/include
-I/usr/local/openssl/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
-I/usr/local/include -L/usr/local/lib/sparcv9 -L/usr/local/openldap/lib
-L/usr/local/sasl/lib -L/usr/local/kerberos/lib -L/usr/local/BerkeleyDB.4.1/lib
-L/usr/local/openssl/lib -R/usr/local/samba/lib -R/opt/samba/lib
-R\$$ORIGIN/../lib -R/usr/local/lib/sparcv9 -R/usr/local/openldap/lib
-R/usr/local/sasl/lib -R/usr/local/kerberos/lib -R/usr/local/BerkeleyDB.4.1/lib
-R/usr/local/openssl/lib -L/usr/local/lib conftest.c  -liconv >&5
configure:19758: $? = 0
configure:19761: test -s conftest
configure:19764: $? = 0
configure:19805: result: yes
configure:19849: checking can we convert from CP850 to UCS2-LE?
configure:19869: cc -o conftest -xarch=v9a -D__EXTENSIONS__ -I/usr/local/include
-I/usr/local/openldap/include -I/usr/local/sasl/include
-I/usr/local/kerberos/include -I/usr/local/BerkeleyDB.4.1/include
-I/usr/local/openssl/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
-I/usr/local/include -I/usr/local/include  -L/usr/local/lib conftest.c -lsec
-lgen -lresolv -lsocket -lnsl -ldl  -L/usr/local/lib -liconv >&5
ld: fatal: library -liconv: not found
ld: fatal: File processing errors. No output written to conftest

Note that the compile line for 

   checking can we convert from CP850 to UCS2-LE

is missing the proper LDFLAGS.
Comment 1 Gerald (Jerry) Carter 2003-11-17 08:13:53 UTC

*** This bug has been marked as a duplicate of 570 ***
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:27:06 UTC
database cleanup