Bug 7840 - Windows 7 Pro unable to join Samba 3.3.4 domain
Windows 7 Pro unable to join Samba 3.3.4 domain
Status: RESOLVED DUPLICATE of bug 7839
Product: Samba 3.3
Classification: Unclassified
Component: Domain Control
3.3.4
x86 Linux
: P3 normal
: ---
Assigned To: Guenther Deschner
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-03 18:18 UTC by Kevin
Modified: 2010-12-04 02:33 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin 2010-12-03 18:18:47 UTC
I'm running a Linux server with Samba 3.3.7. It is configured as a domain controller. I have a Windows 7 Pro laptop which I'm having trouble adding to the Samba domain. I've made all the required Windows registry changes. Below is my smb.conf file. 

Below is output from the Windows 7 NetSetup.LOG when I attempt to join the domain. 

12/02/2010 09:01:54:698 NetpDoDomainJoin
12/02/2010 09:01:54:698 NetpMachineValidToJoin: 'LANPC1'
12/02/2010 09:01:54:698  OS Version: 6.1
12/02/2010 09:01:54:698  Build number: 7600 (7600.win7_gdr.100618-1621)
12/02/2010 09:01:54:702  SKU: Windows 7 Professional
12/02/2010 09:01:54:702 NetpDomainJoinLicensingCheck: ulLicenseValue=1, Status: 0x0
12/02/2010 09:01:54:702 NetpGetLsaPrimaryDomain: status: 0x0
12/02/2010 09:01:54:702 NetpMachineValidToJoin: status: 0x0
12/02/2010 09:01:54:702 NetpJoinDomain
12/02/2010 09:01:54:702  Machine: LANPC1
12/02/2010 09:01:54:702  Domain: LANSYS
12/02/2010 09:01:54:702  MachineAccountOU: (NULL)
12/02/2010 09:01:54:702  Account: LANSYS\kevin
12/02/2010 09:01:54:702  Options: 0x25
12/02/2010 09:01:54:702 NetpLoadParameters: loading registry parameters...
12/02/2010 09:01:54:702 NetpLoadParameters: DNSNameResolutionRequired not found, defaulting to '1' 0x2
12/02/2010 09:01:54:702 NetpLoadParameters: status: DomainCompatibilityMode set to '1'
12/02/2010 09:01:54:702 NetpLoadParameters: status: 0x0
12/02/2010 09:01:54:702 NetpValidateName: checking to see if 'LANSYS' is valid as type 3 name
12/02/2010 09:01:54:804 NetpCheckDomainNameIsValid [ Exists ] for 'LANSYS' returned 0x0
12/02/2010 09:01:54:804 NetpValidateName: name 'LANSYS' is valid for type 3
12/02/2010 09:01:54:804 NetpDsGetDcName: trying to find DC in domain 'LANSYS', flags: 0x40001020
12/02/2010 09:02:02:312 NetpDsGetDcName: failed to find a DC in the specified domain: 0x54b, last error is 0x0
12/02/2010 09:02:02:312 NetpJoinDomainOnDs: NetpDsGetDcName returned: 0x54b
12/02/2010 09:02:02:312 NetpJoinDomainOnDs: Function exits with status of: 0x54b
12/02/2010 09:02:02:312 NetpDoDomainJoin: status: 0x54b

When I do attempt to register into the domain I receive the error message that
my laptop could not "join the domain because the domain either doen't exist or
could not be contacted".

The strange thing is that I can see and access the shares on the Linux server
when I got into the Windows Explorer (file manager). I can even map drives from the Linux shares using \\domain-name\share-name.

#### Samba config file ####

[global]
 workgroup = LANSYS
 server string = Samba 3.3.7 PDC
 netbios name = LNX01
 security = user
 log file = /var/log/samba/%m.log
 max log size = 50
 os level = 65
 preferred master = yes
 local master = yes
 domain master = yes
 domain logons = yes
 encrypt passwords = yes
 wins support = yes
 dns proxy = No
 hosts allow = 192.168.0., 127.
 passdb backend = smbpasswd:/usr/local/samba/private/smbpasswd
 smb passwd file = /usr/local/samba/private/smbpasswd
 logon path = \\%L\Profiles\%U
 logon home = \\%L\%U
 logon drive = H:
 logon script = dummy.bat
[homes]
 browseable = no
 writeable = yes
 create mask = 644
 directory mask = 755
[temp]
 comment = Temp Directory
 path = /tmp
 writeable = yes
 guest ok = yes
[netlogon]
 path = /home/samba/netlogon
 guest ok = yes
 writeable = no
[profiles]
 path = /home/samba/profiles
 read only = no
 create mask = 0600
 directory mask = 0700
Comment 1 Stefan Metzmacher 2010-12-04 02:33:50 UTC

*** This bug has been marked as a duplicate of bug 7839 ***