Bug 7833 - "UTF8" charset name is wrong in Samba3.0.3 release code
"UTF8" charset name is wrong in Samba3.0.3 release code
Status: RESOLVED WORKSFORME
Product: Samba 3.2
Classification: Unclassified
Component: Config Files
unspecified
Other Windows XP
: P3 major
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-30 20:59 UTC by LiXiubao
Modified: 2010-12-01 03:05 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description LiXiubao 2010-11-30 20:59:27 UTC
I tried to import Samba3.0.3 release to MIPS target with kernel-2.6.21.x, when I run smbd on the target, will report below error:

" Probing module 'UTF-8' Probing module 'UTF-8': Trying to load from /lib/charset/UTF-8.so 
Error loading module '/lib/charset/UTF-8.so': File not found init_iconv: Conversion from UTF-8 to UCS-2LE not supported
init_iconv: Attempting to replace with conversion from ASCII to UCS-2LE Substituting charset 'ASCII' for LOCALE
......
convert_string_internal: Conversion error: Incomplete multibyte sequence(€)
convert_string_internal: Conversion error: Incomplete multibyte sequence(?) 
"
Comment 1 LiXiubao 2010-11-30 21:03:56 UTC
I try to find the root cause, in function char *charset_name(charset_t ch) will return the charset name according to the charset_t number, for the CH_DISPLAY will return the local codeset calling function nl_langinfo().

nl_langinfo() return the local support codeset name and the codeset name return "UTF-8", but in the samba 3.0.3 source code define charset name "UTF8", so I get the error report when I run smbd in the target.

Could you confirm "UTF8" name is wrong or not in the samba 3.0.3 source code, thanks!
Comment 2 Björn Jacke 2010-12-01 03:05:22 UTC
3.0.3 is no longer supported. Please test with the latest 3.5 release. If it still happens there, please reopen and add some details about your OS.