Bug 7831 - initialize *output in srv_winreg_nt.c
initialize *output in srv_winreg_nt.c
Status: RESOLVED DUPLICATE of bug 7617
Product: Samba 3.5
Classification: Unclassified
Component: Winbind
3.5.6
Other Windows XP
: P3 normal
: ---
Assigned To: Michael Adam
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-29 16:53 UTC by Grace Chen
Modified: 2010-11-29 17:37 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Grace Chen 2010-11-29 16:53:41 UTC
We saw that winbind coredumps if client send packets that query the server performance counters.

This is due to an uninitialized variable used. The issue can be fixed as:

In function _winreg_QueryValue(), source file source3/rpc_server/srv_winreg_nt.c
 
Following line should be changed:
uint8_t *outbuf;
 
to
 
uint8_t *outbuf = NULL;
Comment 1 Michael Adam 2010-11-29 17:30:20 UTC
Hi Grace,

thanks for the bug report!

This is actually a duplicate of bug #7617.
This has been fixed in 3.5.6.
(http://samba.org/samba/history/samba-3.5.6.html)

So, have you really been looking into 3.5.6 code, or
possibly rather into 3.5.5. or earlier?

Best regards,
Michael

*** This bug has been marked as a duplicate of bug 7617 ***
Comment 2 Grace Chen 2010-11-29 17:37:18 UTC
That's great! Sorry I was looking at 3.5.5.  
Thanks, -Grace