Bug 7830 - undefined reference to `talloc_free, need help on this, how to correct this error
undefined reference to `talloc_free, need help on this, how to correct this e...
Status: RESOLVED WONTFIX
Product: Samba 4.0
Classification: Unclassified
Component: Build
unspecified
Other Linux
: P3 normal
: ---
Assigned To: Andrew Tridgell
samba4-qa@samba.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-29 13:00 UTC by leonardo
Modified: 2010-12-03 04:00 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description leonardo 2010-11-29 13:00:55 UTC
this is my output when I try to compile samba 4.0.0 alpha 7 in Ubuntu using the spec file provided in the samba packages:
bin/mergedobj/samba_socket.o: In function `socket_connect_send':
(.text+0x2605): undefined reference to `_talloc_reference'
bin/mergedobj/samba_socket.o: In function `socket_connect_send':
(.text+0x263e): undefined reference to `_talloc_reference'
bin/mergedobj/samba_socket.o: In function `socket_connect_recv':
(.text+0x2774): undefined reference to `talloc_free'
bin/mergedobj/socket_unix.o: In function `unixdom_get_peer_addr':
socket_unix.c:(.text+0xb53): undefined reference to `talloc_free'
socket_unix.c:(.text+0xba2): undefined reference to `talloc_free'
socket_unix.c:(.text+0xbec): undefined reference to `talloc_free'
bin/mergedobj/socket_unix.o: In function `unixdom_get_my_addr':
socket_unix.c:(.text+0xc81): undefined reference to `talloc_free'
bin/mergedobj/socket_unix.o:socket_unix.c:(.text+0xcd0): more undefined references to `talloc_free' follow
bin/mergedobj/cli_resolve.o: In function `resolve_name_all_send':
(.text+0x40c): undefined reference to `_talloc_reference'
bin/mergedobj/cli_resolve.o: In function `resolve_name_all_recv':
(.text+0x6b5): undefined reference to `_talloc_steal'
bin/mergedobj/cli_resolve.o: In function `resolve_name_all_recv':
(.text+0x6db): undefined reference to `_talloc_steal'
bin/mergedobj/cli_resolve.o: In function `resolve_name_all_recv':
(.text+0x6f1): undefined reference to `talloc_free'
bin/mergedobj/cli_resolve.o: In function `resolve_name_recv':
(.text+0x7ab): undefined reference to `_talloc_steal'
bin/mergedobj/cli_resolve.o: In function `resolve_name_recv':
(.text+0x7c1): undefined reference to `talloc_free'
bin/mergedobj/ndr_nbt_buf.o: In function `ndr_push_nbt_string':
(.text+0x581): undefined reference to `talloc_free'
bin/mergedobj/ndr_nbt_buf.o: In function `ndr_pull_nbt_name':
(.text+0x95e): undefined reference to `talloc_free'
bin/mergedobj/ndr_nbt_buf.o: In function `ndr_push_nbt_name':
(.text+0xa45): undefined reference to `talloc_free'
bin/mergedobj/ndr_nbt_buf.o: In function `nbt_name_string':
(.text+0xf3f): undefined reference to `talloc_free'
bin/mergedobj/ndr_nbt_buf.o:(.text+0x124f): more undefined references to `talloc_free' follow
bin/mergedobj/cli_composite.o: In function `composite_create':
(.text+0x56): undefined reference to `_talloc_reference'
bin/mergedobj/cli_composite.o: In function `composite_create':
(.text+0x73): undefined reference to `talloc_free'
bin/mergedobj/cli_composite.o: In function `composite_wait_free':
(.text+0x11d): undefined reference to `talloc_free'
bin/mergedobj/secrets.o: In function `secrets_init':
(.text+0x10b): undefined reference to `talloc_free'
bin/mergedobj/secrets.o: In function `secrets_init':
(.text+0x116): undefined reference to `talloc_free'
bin/mergedobj/secrets.o: In function `secrets_init':
(.text+0x128): undefined reference to `talloc_free'
bin/mergedobj/secrets.o:(.text+0x1e5): more undefined references to `talloc_free' follow
bin/mergedobj/tdb_wrap.o: In function `tdb_wrap_open':
(.text+0x20a): undefined reference to `_talloc_reference'
bin/mergedobj/tdb_wrap.o: In function `tdb_wrap_open':
(.text+0x2b5): undefined reference to `talloc_free'
bin/mergedobj/cli_auth.o: In function `creds_step':
credentials.c:(.text+0x3b7): undefined reference to `talloc_free'
credentials.c:(.text+0x444): undefined reference to `talloc_free'
credentials.c:(.text+0x4d5): undefined reference to `talloc_free'
credentials.c:(.text+0x565): undefined reference to `talloc_free'
bin/mergedobj/cli_auth.o:credentials.c:(.text+0x5f6): more undefined references to `talloc_free' follow
bin/mergedobj/ndr_drsuapi.o: In function `ndr_pull_drsuapi_DsReplicaOID':
(.text+0x4d41d): undefined reference to `_talloc_steal'
bin/mergedobj/ndr_drsuapi.o: In function `ndr_push_drsuapi_DsGetNCChangesMSZIPCtr1':
(.text+0x4d63b): undefined reference to `talloc_free'
bin/mergedobj/ndr_drsuapi.o: In function `ndr_push_drsuapi_DsGetNCChangesMSZIPCtr6':
(.text+0x4d913): undefined reference to `talloc_free'
bin/mergedobj/ndr_drsuapi.o: In function `ndr_push_drsuapi_DsGetNCChangesXPRESSCtr1':
(.text+0x4dbeb): undefined reference to `talloc_free'
bin/mergedobj/ndr_drsuapi.o: In function `ndr_push_drsuapi_DsGetNCChangesXPRESSCtr6':
(.text+0x4dec3): undefined reference to `talloc_free'
bin/mergedobj/asn1_util.o: In function `asn1_init':
(.text+0x82): undefined reference to `talloc_free'
bin/mergedobj/asn1_util.o:(.text+0xa8): more undefined references to `talloc_free' follow
bin/mergedobj/ndr_compression.o: In function `ndr_pull_compression_start':
(.text+0xeb4): undefined reference to `_talloc_reference'
bin/mergedobj/ndr_compression.o: In function `ndr_push_compression_end':
(.text+0xfe6): undefined reference to `_talloc_reference'
bin/mergedobj/ndr_compression.o: In function `ndr_push_compression_end':
(.text+0x10c2): undefined reference to `talloc_free'
bin/mergedobj/ndr.o: In function `ndr_pull_string':
(.text+0x3e0): undefined reference to `talloc_free'
bin/mergedobj/ndr.o: In function `ndr_pull_string':
(.text+0x461): undefined reference to `talloc_free'
bin/mergedobj/ndr.o: In function `ndr_pull_string':
(.text+0x4ce): undefined reference to `talloc_free'
bin/mergedobj/ndr.o: In function `ndr_pull_string':
(.text+0x6b1): undefined reference to `talloc_free'
bin/mergedobj/ndr.o:(.text+0x71e): more undefined references to `talloc_free' follow
bin/mergedobj/ndr.o: In function `ndr_pull_init_blob':
(.text+0x5edc): undefined reference to `_talloc_reference'
bin/mergedobj/ndr.o: In function `ndr_push_init_ctx':
(.text+0x6051): undefined reference to `_talloc_reference'
bin/mergedobj/ndr.o: In function `ndr_print_debug_helper':
(.text+0x625d): undefined reference to `talloc_free'
bin/mergedobj/ndr.o: In function `ndr_print_debug_helper':
(.text+0x62a3): undefined reference to `talloc_free'
bin/mergedobj/ndr.o: In function `ndr_print_debug':
(.text+0x63ad): undefined reference to `talloc_free'
bin/mergedobj/ndr.o: In function `ndr_print_debug':
(.text+0x6417): undefined reference to `talloc_free'
bin/mergedobj/ndr.o: In function `ndr_print_union_debug':
(.text+0x6480): undefined reference to `talloc_free'
bin/mergedobj/ndr.o:(.text+0x6503): more undefined references to `talloc_free' follow
bin/mergedobj/ndr.o: In function `ndr_print_struct_string':
(.text+0x66a1): undefined reference to `_talloc_steal'
bin/mergedobj/ndr.o: In function `ndr_print_struct_string':
(.text+0x66b8): undefined reference to `talloc_free'
bin/mergedobj/ndr.o: In function `ndr_print_union_string':
(.text+0x6795): undefined reference to `_talloc_steal'
bin/mergedobj/ndr.o: In function `ndr_print_union_string':
(.text+0x67ac): undefined reference to `talloc_free'
bin/mergedobj/ndr.o: In function `ndr_print_function_string':
(.text+0x6877): undefined reference to `_talloc_steal'
bin/mergedobj/ndr.o: In function `ndr_print_function_string':
(.text+0x688e): undefined reference to `talloc_free'
bin/mergedobj/ndr.o: In function `ndr_pull_error':
(.text+0x69c2): undefined reference to `talloc_free'
bin/mergedobj/ndr.o: In function `ndr_push_error':
(.text+0x6a7a): undefined reference to `talloc_free'
bin/mergedobj/ndr.o: In function `ndr_pull_subcontext_start':
(.text+0x6f25): undefined reference to `_talloc_reference'
bin/mergedobj/ndr.o: In function `ndr_token_retrieve_cmp_fn':
(.text+0x74c5): undefined reference to `talloc_free'
bin/mergedobj/ndr.o: In function `ndr_push_struct_blob':
(.text+0x7c09): undefined reference to `_talloc_steal'
bin/mergedobj/ndr.o: In function `ndr_push_struct_blob':
(.text+0x7c17): undefined reference to `talloc_free'
bin/mergedobj/ndr.o: In function `ndr_push_union_blob':
(.text+0x7ce4): undefined reference to `_talloc_steal'
bin/mergedobj/ndr.o: In function `ndr_push_union_blob':
(.text+0x7cf2): undefined reference to `talloc_free'
bin/mergedobj/ndr.o: In function `ndr_size_struct':
(.text+0x7d8b): undefined reference to `talloc_free'
bin/mergedobj/ndr.o: In function `ndr_size_struct':
(.text+0x7da6): undefined reference to `talloc_free'
bin/mergedobj/ndr.o: In function `ndr_size_union':
(.text+0x7e3b): undefined reference to `talloc_free'
bin/mergedobj/ndr.o: In function `ndr_size_union':
(.text+0x7e70): undefined reference to `talloc_free'
bin/mergedobj/ndr.o:(.text+0x7e8b): more undefined references to `talloc_free' follow
bin/mergedobj/tevent.o: In function `tevent_backend_list':
(.text+0x1b2): undefined reference to `_talloc_steal'
bin/mergedobj/tevent.o: In function `tevent_common_context_destructor':
(.text+0x1e8): undefined reference to `talloc_free'
bin/mergedobj/tevent.o: In function `tevent_context_init_ops':
tevent.c:(.text+0x489): undefined reference to `talloc_free'
bin/mergedobj/tevent.o: In function `tevent_common_loop_timer_delay':
(.text+0x1100): undefined reference to `talloc_free'
bin/mergedobj/tevent.o: In function `tevent_signal_destructor':
tevent_signal.c:(.text+0x1439): undefined reference to `talloc_free'
tevent_signal.c:(.text+0x14c0): undefined reference to `talloc_free'
bin/mergedobj/tevent.o:(.text+0x1681): more undefined references to `talloc_free' follow
bin/mergedobj/tevent.o: In function `tevent_common_add_signal':
(.text+0x16b2): undefined reference to `_talloc_reference'
bin/mergedobj/tevent.o: In function `tevent_common_add_signal':
(.text+0x16c1): undefined reference to `talloc_free'
bin/mergedobj/tevent.o: In function `tevent_common_add_signal':
(.text+0x17a4): undefined reference to `talloc_free'
bin/mergedobj/tevent.o: In function `tevent_common_add_signal':
(.text+0x17fd): undefined reference to `talloc_free'
bin/mergedobj/tevent.o: In function `tevent_common_add_signal':
(.text+0x1840): undefined reference to `talloc_free'
bin/mergedobj/tevent.o: In function `tevent_common_add_signal':
(.text+0x19a2): undefined reference to `talloc_free'
bin/mergedobj/tevent.o:(.text+0x1a4f): more undefined references to `talloc_free' follow
bin/mergedobj/tdr.o: In function `tdr_push_init':
(.text+0x1259): undefined reference to `_talloc_reference'
bin/mergedobj/tdr.o: In function `tdr_pull_init':
(.text+0x12bb): undefined reference to `_talloc_reference'
bin/mergedobj/tdr.o: In function `tdr_push_to_fd':
(.text+0x1382): undefined reference to `talloc_free'
bin/mergedobj/tdr.o: In function `tdr_push_to_fd':
(.text+0x138d): undefined reference to `talloc_free'
bin/mergedobj/tdr.o: In function `tdr_push_to_fd':
(.text+0x1410): undefined reference to `talloc_free'
bin/mergedobj/tdr.o: In function `tdr_push_to_fd':
(.text+0x1423): undefined reference to `talloc_free'
bin/mergedobj/tdr.o: In function `tdr_print_debug_helper':
(.text+0x14c6): undefined reference to `talloc_free'
bin/mergedobj/tdr.o:(.text+0x1529): more undefined references to `talloc_free' follow
bin/mergedobj/samba-hostconfig.o: In function `.L633':
loadparm.c:(.text+0x2593): undefined reference to `_talloc_reference'
loadparm.c:(.text+0x2603): undefined reference to `_talloc_reference'
loadparm.c:(.text+0x2620): undefined reference to `_talloc_reference'
bin/mergedobj/samba-hostconfig.o: In function `service_ok':
loadparm.c:(.text+0x2708): undefined reference to `talloc_free'
loadparm.c:(.text+0x2756): undefined reference to `talloc_free'
loadparm.c:(.text+0x27d6): undefined reference to `talloc_free'
loadparm.c:(.text+0x2855): undefined reference to `talloc_free'
bin/mergedobj/samba-hostconfig.o: In function `add_to_file_list':
loadparm.c:(.text+0x291c): undefined reference to `talloc_free'
bin/mergedobj/samba-hostconfig.o:loadparm.c:(.text+0x294b): more undefined references to `talloc_free' follow
bin/mergedobj/samba-hostconfig.o: In function `lp_dcerpc_server_info':
(.text+0x65cd): undefined reference to `_talloc_reference'
bin/mergedobj/samba-hostconfig.o: In function `lp_gensec_settings':
(.text+0x6734): undefined reference to `talloc_free'
bin/mergedobj/samba-hostconfig.o: In function `lp_gensec_settings':
(.text+0x6746): undefined reference to `_talloc_reference'
bin/mergedobj/samba-hostconfig.o: In function `param_get_add':
(.text+0x69da): undefined reference to `talloc_free'
bin/mergedobj/samba-hostconfig.o: In function `param_get_add':
(.text+0x6a4a): undefined reference to `talloc_free'
bin/mergedobj/samba-hostconfig.o: In function `param_pfunc':
generic.c:(.text+0x70d7): undefined reference to `talloc_free'
bin/mergedobj/samba-hostconfig.o: In function `lock_path':
(.text+0x75a5): undefined reference to `talloc_free'
bin/mergedobj/samba-hostconfig.o: In function `config_path':
(.text+0x7644): undefined reference to `talloc_free'
bin/mergedobj/samba-hostconfig.o:(.text+0x7776): more undefined references to `talloc_free' follow
bin/mergedobj/samba-util.o: In function `file_lines_parse':
(.text+0x595c): undefined reference to `_talloc_steal'
bin/mergedobj/samba-util.o: In function `data_blob_talloc_named':
(.text+0x5ee7): undefined reference to `_talloc_steal'
bin/mergedobj/samba-util.o: In function `data_blob_talloc_reference':
(.text+0x5f3b): undefined reference to `_talloc_reference'
bin/mergedobj/samba-util.o: In function `data_blob_free':
(.text+0x6012): undefined reference to `talloc_free'
bin/mergedobj/samba-util.o: In function `directory_create_or_exist':
(.text+0x65e7): undefined reference to `talloc_free'
bin/mergedobj/samba-util.o: In function `directory_create_or_exist':
(.text+0x6664): undefined reference to `talloc_free'
bin/mergedobj/samba-util.o: In function `directory_create_or_exist':
(.text+0x66dd): undefined reference to `talloc_free'
bin/mergedobj/samba-util.o: In function `directory_create_or_exist':
(.text+0x675c): undefined reference to `talloc_free'
bin/mergedobj/samba-util.o:(.text+0x68ff): more undefined references to `talloc_free' follow
collect2: ld returned 1 exit status
make: *** [bin/regpatch] Error 1
Comment 1 Matthias Dieter Wallnöfer 2010-12-03 04:00:20 UTC
You seem to be using very outdated versions. I've confirmed with other team members that it's much better to use recent Debian- and Ubuntu-specific packages.

Here the links:
- http://bzr.debian.org/pkg-samba/samba4/unstable/ (repo)
- https://launchpad.net/~samba-team/+archive/ppa (packages)

For questions: jelmer@samba.org (Jelmer Vernooij)

I'm marking this as "WONTFIX" since the new packages should work - if not please contact Jelmer.