Bug 7801 - Not build crosscompile samba4.0.0alpha13
Not build crosscompile samba4.0.0alpha13
Status: RESOLVED WONTFIX
Product: Samba 4.0
Classification: Unclassified
Component: Build
unspecified
Other Linux
: P3 normal
: ---
Assigned To: Andrew Tridgell
samba4-qa@samba.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-19 04:55 UTC by Strizhevsky Alexander
Modified: 2011-02-09 13:00 UTC (History)
0 users

See Also:


Attachments
build log (5.82 KB, text/plain)
2010-11-19 04:56 UTC, Strizhevsky Alexander
no flags Details
configure config log (45.76 KB, text/plain)
2010-11-19 04:56 UTC, Strizhevsky Alexander
no flags Details
configure check directory (7.05 KB, application/x-bzip2)
2010-11-22 04:12 UTC, Strizhevsky Alexander
no flags Details
test mipsel-gcc linking testprog - OK! (416 bytes, application/octet-stream)
2010-11-22 04:18 UTC, Strizhevsky Alexander
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Strizhevsky Alexander 2010-11-19 04:55:17 UTC
Not build crosscompile samba4.0.0alpha13 for OpenWrt (mipsel/gcc 4.4.5/eglibc 2.12)
Comment 1 Strizhevsky Alexander 2010-11-19 04:56:00 UTC
Created attachment 6074 [details]
build log
Comment 2 Strizhevsky Alexander 2010-11-19 04:56:45 UTC
Created attachment 6075 [details]
configure config log
Comment 3 Matthias Dieter Wallnöfer 2010-11-21 03:53:44 UTC
Partial output from the configure log:
> /home/sysadmin/wl500/OpenWrt/SDK/build_dir/target-mipsel_eglibc-2.12/samba-4.0.0alpha13/source4/bin/.conf_check_0/testbuild/default/testprog: In function `_fini':
(.fini+0x0): multiple definition of `_fini'
> /home/sysadmin/wl500/OpenWrt/SDK/staging_dir/toolchain-mipsel_gcc-4.4.5_eglibc-2.12/bin/../lib/gcc/mipsel-openwrt-linux-gnu/4.4.5/../../../../mipsel-openwrt-linux-gnu/lib/crti.o:(.fini+0x0): first defined here
> /home/sysadmin/wl500/OpenWrt/SDK/build_dir/target-mipsel_eglibc-2.12/samba-4.0.0alpha13/source4/bin/.conf_check_0/testbuild/default/testprog:(.got+0x0): multiple definition of `_GLOBAL_OFFSET_TABLE_'
> /home/sysadmin/wl500/OpenWrt/SDK/staging_dir/toolchain-mipsel_gcc-4.4.5_eglibc-2.12/bin/../lib/gcc/mipsel-openwrt-linux-gnu/4.4.5/../../../../mipsel-openwrt-linux-gnu/lib/crti.o:(.got+0x0): first defined here
> /home/sysadmin/wl500/OpenWrt/SDK/build_dir/target-mipsel_eglibc-2.12/samba-4.0.0alpha13/source4/bin/.conf_check_0/testbuild/default/testprog:(.rodata+0x0): multiple definition of `_IO_stdin_used'
> /home/sysadmin/wl500/OpenWrt/SDK/staging_dir/toolchain-mipsel_gcc-4.4.5_eglibc-2.12/bin/../lib/gcc/mipsel-openwrt-linux-gnu/4.4.5/../../../../mipsel-openwrt-linux-gnu/lib/crt1.o:(.rodata.cst4+0x0): first defined here
> /home/sysadmin/wl500/OpenWrt/SDK/build_dir/target-mipsel_eglibc-2.12/samba-4.0.0alpha13/source4/bin/.conf_check_0/testbuild/default/testprog: In function `_fdata':
> (.data+0x0): multiple definition of `__data_start'

Please fix those linking issues. All these error messages have nothing to do with our code, only with your stdlibc and the simple testprograms from the buildsystem. Probably you need some additional compiler options or definitions (#define...) in order to prevent multiple symbols.

If afterward other issues come up then please report them here. But be aware: since we are using WAF as our building framework first make sure that it is compatible with your compiler.
Comment 4 Strizhevsky Alexander 2010-11-22 04:12:17 UTC
Created attachment 6078 [details]
configure check directory
Comment 5 Strizhevsky Alexander 2010-11-22 04:18:21 UTC
Created attachment 6079 [details]
test mipsel-gcc linking testprog - OK!

Run the test program from the command line occurred successfully. What can I do next? The problem WAF?
Comment 6 Matthias Dieter Wallnöfer 2010-11-22 06:16:19 UTC
Well, I'm not really a build system expert as tridge or jelmer. It would be nice if they could comment on if it makes sense to ask the WAF project for help.

But I'm still thinking that your cross-compiler is somehow misconfigured. You shouldn't get all these "collect2" (linker) errors.
Comment 7 Strizhevsky Alexander 2010-11-22 06:59:10 UTC
(In reply to comment #6)
> Well, I'm not really a build system expert as tridge or jelmer. It would be
> nice if they could comment on if it makes sense to ask the WAF project for
> help.
> 
> But I'm still thinking that your cross-compiler is somehow misconfigured. You
> shouldn't get all these "collect2" (linker) errors.
> 

Run the test_mipsel_gcc no (linker) errors!
Comment 8 Matthias Dieter Wallnöfer 2010-12-03 07:52:06 UTC
Well, I've talked to tridge - our WAF buildsystem guru - and also he has no clue. He would need to reproduce this himself.

What you could do is to ask our "WAF connection" (a WAF developer) Thomas Nagy - tnagy1024@gmail.com. But also here I'm not sure if he really has more knowledge regarding cross-compilation.
Comment 9 Matthias Dieter Wallnöfer 2011-01-21 07:10:32 UTC
Did you come any further here? Or did you contact Thomas Nagy?

Otherwise I'll have to close this with "WONTFIX" since we simply don't have the resources to fix this.
But if you want to fix this on your own and prefer to have some help in form of questions, then please contact us on the technical mailing list or IRC chat.
Comment 10 Matthias Dieter Wallnöfer 2011-02-09 13:00:30 UTC
Closing with "WONTFIX".