Bug 7796 - getent {passwd,group} gives no output
getent {passwd,group} gives no output
Status: RESOLVED DUPLICATE of bug 7594
Product: Samba 3.5
Classification: Unclassified
Component: Winbind
3.5.6
x64 Linux
: P3 major
: ---
Assigned To: Michael Adam
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-16 10:47 UTC by rem
Modified: 2010-11-17 03:53 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rem 2010-11-16 10:47:08 UTC
Hi,

The issue is on a Debian server, using samba and winbind 3.5.6.

# wbinfo -t
checking the trust secret for domain 3S-LAB via RPC calls succeeded

# net ads testjoin
Join is OK

logs when trying to retrieve users :

/var/log/samba/log.winbindd
[2010/11/16 17:38:27.467870,  6] winbindd/winbindd.c:768(new_connection)
  accepted socket 28
[2010/11/16 17:38:27.467958,  3] winbindd/winbindd_misc.c:352(winbindd_interface_version)
  [ 4547]: request interface version
[2010/11/16 17:38:27.468172,  3] winbindd/winbindd_misc.c:385(winbindd_priv_pipe_dir)
  [ 4547]: request location of privileged pipe
[2010/11/16 17:38:27.468385,  6] winbindd/winbindd.c:768(new_connection)
  accepted socket 29
[2010/11/16 17:38:27.468505,  6] winbindd/winbindd.c:816(winbind_client_request_read)
  closing socket 28, client exited
[2010/11/16 17:38:27.468541,  3] winbindd/winbindd_getpwent.c:50(winbindd_getpwent_send)
  [ 4547]: getpwent
[2010/11/16 17:38:27.469465,  1] ../librpc/ndr/ndr.c:395(ndr_pull_error)
  ndr_pull_error(1): String terminator not present or outside string boundaries
[2010/11/16 17:38:27.469893,  6] winbindd/winbindd.c:816(winbind_client_request_read)
  closing socket 29, client exited

nothing in log.winbindd-dc-connect nor in log.winbindd-idmap


Cheers,
rc
Comment 1 Stefan Metzmacher 2010-11-17 01:30:35 UTC
If you "unix charset != UTF8" it's a duplicate of
https://bugzilla.samba.org/show_bug.cgi?id=7594

Can you test this patches
https://bugzilla.samba.org/attachment.cgi?id=6042
or the current v3-5-test git branch?
Comment 2 Michael Adam 2010-11-17 02:11:30 UTC
(In reply to comment #1)
> If you "unix charset != UTF8" it's a duplicate of
> https://bugzilla.samba.org/show_bug.cgi?id=7594
> 
> Can you test this patches
> https://bugzilla.samba.org/attachment.cgi?id=6042
> or the current v3-5-test git branch?

Right from the log messages "ndr_pull_error(1): String terminator not present or outside string boundaries" in winbindd communication, I also guess that this is a duplicate of Bug #7594. Of course, this needs verification (by comparing your smb.conf , especially the "unix charset" parameter).

Comment 3 rem 2010-11-17 03:13:57 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > If you "unix charset != UTF8" it's a duplicate of
> > https://bugzilla.samba.org/show_bug.cgi?id=7594

Oh, yes, I didnt' found this bug report when searching for (even with the ndr_pull_error keyword).

> > Can you test this patches
> > https://bugzilla.samba.org/attachment.cgi?id=6042
> > or the current v3-5-test git branch?

I will test it on our test server. For now, changing 
unix charset = iso8859-15
for
unix charset = UTF8
works for me. Seems to be the same issue.

I resolve bug as duplicate.

Cheers,
rc

> 
> Right from the log messages "ndr_pull_error(1): String terminator not present
> or outside string boundaries" in winbindd communication, I also guess that this
> is a duplicate of Bug #7594. Of course, this needs verification (by comparing
> your smb.conf , especially the "unix charset" parameter).
> 



*** This bug has been marked as a duplicate of bug 7594 ***
Comment 4 Stefan Metzmacher 2010-11-17 03:35:34 UTC
Please note that if you change unix charset to utf8, you might
need to use 'convmv' to change the file names on disk.
Otherwise you may serve corrupted file names to the clients. 
Comment 5 rem 2010-11-17 03:43:54 UTC
Yes, I dunno that. Thx for your advice !

Cheers,
rc


(In reply to comment #4)
> Please note that if you change unix charset to utf8, you might
> need to use 'convmv' to change the file names on disk.
> Otherwise you may serve corrupted file names to the clients. 
> 

Comment 6 Michael Adam 2010-11-17 03:53:27 UTC
(In reply to comment #5)
> Yes, I dunno that. Thx for your advice !

So depending on the (amount of) files you have,
it might be better to use a patched version of
samba or wait for 3.5.7... But as Metze said,
convmv is there to help you ... :-)

> Cheers,
> rc
> 
> 
> (In reply to comment #4)
> > Please note that if you change unix charset to utf8, you might
> > need to use 'convmv' to change the file names on disk.
> > Otherwise you may serve corrupted file names to the clients. 
> > 
>