Bug 7773 - Please add a switch to preserve ownership on the receiving side
Please add a switch to preserve ownership on the receiving side
Status: RESOLVED DUPLICATE of bug 3829
Product: rsync
Classification: Unclassified
Component: core
All Linux
: P3 enhancement
: ---
Assigned To: Wayne Davison
Rsync QA Contact
Depends on:
  Show dependency treegraph
Reported: 2010-11-02 15:22 UTC by Aleksey Tsalolikhin
Modified: 2010-11-06 13:18 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Aleksey Tsalolikhin 2010-11-02 15:22:39 UTC
Hi.  Thanks for a great program!  Could you please add a switch to preserve user and group ownership on the receiver?  I only want the content copied across (and not in-place either, the file is in use).

Comment 1 Wayne Davison 2010-11-06 10:56:13 UTC
Specify --owner (and possibly --group, or just use --archive).  Just make sure the receiver is authorized to set ownership (you can use --super to force it to try).
Comment 2 Matt McCutchen 2010-11-06 13:16:58 UTC
I think the request is for recreated destination files to keep the same ownership they had, rather than taking the default ownership of the receiver, when --owner and --group are off.  (Of course, this will only work for the receiving rsync's groups when --super mode is off.)
Comment 3 Matt McCutchen 2010-11-06 13:18:33 UTC
I'm merging this with bug 3829, which described the analogous issue with ACLs and xattrs.

*** This bug has been marked as a duplicate of bug 3829 ***