Bug 7751 - Can't upload printer drivers, because 'add' button disabled
Can't upload printer drivers, because 'add' button disabled
Status: RESOLVED FIXED
Product: Samba 3.5
Classification: Unclassified
Component: Printing
3.5.6
x64 Windows XP
: P3 critical
: ---
Assigned To: Guenther Deschner
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-25 14:08 UTC by Marc Muehlfeld
Modified: 2011-03-10 08:47 UTC (History)
0 users

See Also:


Attachments
Level 10 debug log (68.19 KB, application/octet-stream)
2010-10-25 14:09 UTC, Marc Muehlfeld
no flags Details
Screenshot of the Window with the disabled button (49.07 KB, image/png)
2010-10-25 14:10 UTC, Marc Muehlfeld
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2010-10-25 14:08:51 UTC
I made a fresh install with 3.5.6 (so no *.tdb, etc.). If I use XP (haven't tried other OS), open the server, go to file / printer properties / driver, the disabled 'add' button prevents me from uploading printer drivers. I also tested 3.5.4 and 3.5.5 - same issue.

Then I installed 3.3.14 and the 'add' button is enabled again and drivers can be uploaded.

I attach a screenshot and a level 10 debug log
Comment 1 Marc Muehlfeld 2010-10-25 14:09:15 UTC
Created attachment 6032 [details]
Level 10 debug log
Comment 2 Marc Muehlfeld 2010-10-25 14:10:18 UTC
Created attachment 6033 [details]
Screenshot of the Window with the disabled button
Comment 3 Marc Muehlfeld 2010-10-25 14:33:56 UTC
If I upload my drivers using 3.3.14, I can use them on 3.5.6, but the Buttons 'add', 'remove' and 'replace' stay disabled. Only 'properties' gets enabled.
Comment 4 Marc Muehlfeld 2011-03-10 08:47:08 UTC
The problem is gone in 3.5.8.