Bug 7733 - Invalid client DOS attributes on create can cause incorrect unix mode_t to be generated.
Invalid client DOS attributes on create can cause incorrect unix mode_t to be...
Status: RESOLVED DUPLICATE of bug 7716
Product: Samba 3.5
Classification: Unclassified
Component: File services
unspecified
All All
: P3 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-15 13:54 UTC by Jeremy Allison
Modified: 2010-11-01 14:16 UTC (History)
0 users

See Also:


Attachments
git am fix for 3.5.next. (1.65 KB, patch)
2010-10-18 15:36 UTC, Jeremy Allison
vl: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Allison 2010-10-15 13:54:58 UTC
It turns out a client can send an NTCreateX call for a new file, but specify FILE_ATTRIBUTE_DIRECTORY in the attribute list. Windows silently strips this, but we don't - causing the unix_mode() function to go through the "mode bits for new directory" codepath, instead of the "mode bits for new file" codepath.

Patch for 3.5.x to follow.

Jeremy.
Comment 1 Jeremy Allison 2010-10-18 15:36:53 UTC
Created attachment 6017 [details]
git am fix for 3.5.next.

Volker please review then assign to Karolin for inclusion.
Thanks,
Jeremy.
Comment 2 Jeremy Allison 2010-11-01 14:16:04 UTC
This is included in the ACL jumbo patch attached to #7716.
Jeremy.


*** This bug has been marked as a duplicate of bug 7716 ***