Bug 7726 - NT_STATUS_ILLEGAL_CHARACTER -- cifs broken
NT_STATUS_ILLEGAL_CHARACTER -- cifs broken
Status: NEW
Product: CifsVFS
Classification: Unclassified
Component: kernel fs
2.6
x86 Linux
: P3 normal
: ---
Assigned To: Steve French
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-11 06:22 UTC by whynot
Modified: 2011-02-04 16:43 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description whynot 2010-10-11 06:22:10 UTC
I cannot mount a samba share using CIFS. This is a university network, so I don't exactly know what OS the server is running. I am using the following mount command: 

sudo mount -t cifs //xxx.xxx.xxx.xxx/nanomat$ /media/nanomat/ -o cred=/home/xxxx/xxxx/nanomat

I am getting the error "mount error(5): Input/output error". 
Strange thing is that if I use the same credentials file, I can log on using smbclient every single time: 

smbclient -A=/home/xxxx/xxxx/nanomat //xxx.xxx.xxx.xxx/nanomat$

I also use the smb:// slave in Konqueror to access the share all the time. I simply cannot mount it using mount.cifs (but that's what I need to do.)

I have tried to find a solution to this bug for almost two years on and off. I googled around from all angles. I found many similar reports in the forums; many people reporting difficulties with the switch from smbfs to cifs. However, nowhere a solution to this problem. I tried this now across several versions of kubuntu (different kernels); I tried escaping the slashes and the $ sign. I tried using host name vs. IP. Just nothing works. 

After enabling verbose output, I find in syslog that the underlying error is "SMB error code 31", which translates into "NT_STATUS_ILLEGAL_CHARACTER". Could that be because of the $ sign? Strangly, smbclient or smb:// do not seem to have a problem with it. 

I also reported this on various other forums, for instance here (with some more details): 
http://www.linuxquestions.org/questions/linux-networking-3/cant-mount-cifs-share-but-smbclient-and-smb-kio-works-774039/

Just NO solution. Any developers here getting interested in this problem?
Comment 1 whynot 2010-10-11 06:27:10 UTC
Oh, and I am NOT using spaces in the credentials file, which was one of the reported problems/differences between smbmount and cifs. I also tried backslashes instead of forward slashes.
Comment 2 Guenter Kukkukk 2010-11-23 21:54:15 UTC
What kind of smb server are you trying to connect to?
    smbclient -L <servername> -U <some_valid_user>   or
    smbclient -L <ip_of_server> -U <some_valid_user>
will tell like:
Domain=[DOMAIN01] OS=[Unix] Server=[Samba 3.6.0-GIT-097be4b-devel]
In addition it will also list the exported shares.

The $ sign at the end of the share name should make no
difference to cifs.

Btw - share names ending with the $ sign are sometimes called
hidden or administrative shares.
E.g. in the windows world
 C$
 D$
 ...
are administrative shares exporting whole partitions ...

Cheers, Günter

In addition, a network trace might help, too.
http://wiki.samba.org/index.php/Capture_Packets
Comment 3 Shirish S. Pargaonkar 2011-02-04 16:43:29 UTC
I do not think this is a bug in cifs either. I did mount a share ending with
character $ at the end.
What is the version of cifs client as well as Samba server you have?