Bug 771 - SMB Delete Directory Request returns wrong error code
SMB Delete Directory Request returns wrong error code
Status: VERIFIED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.0
All other
: P3 normal
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-13 09:19 UTC by John Bazey
Modified: 2005-11-14 09:26 UTC (History)
0 users

See Also:


Attachments
Ethereal trace of bad return (number 36 and 37 in trace) (9.91 KB, application/octet-stream)
2003-11-13 09:30 UTC, John Bazey
no flags Details
Ethereal trace with correct return code (line 36 and 37) (9.90 KB, application/octet-stream)
2003-11-13 09:33 UTC, John Bazey
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Bazey 2003-11-13 09:19:05 UTC
Doing a SMB Delete Directory Request to a Samba 3.0 server from an iSeries 
using QNTC returns STATUS_NO_SUCH_FILE when it should return 
STATUS_DIRECTORY_NOT_EMPTY.  This happens the first time after a directory or 
file is added to an empty directory and then the Delete Directory Request is 
done against that directory.  Any Delete Directory Request afterwards returns 
the correct error code.  I have Ethereal traces showing the requests and 
responses for both error codes.  If you want them let me know who to send them 
to.
Comment 1 John Bazey 2003-11-13 09:30:18 UTC
Created attachment 253 [details]
Ethereal trace of bad return (number 36 and 37 in trace)

The is the Ethereal trace getting the STATUS_NO_SUCH_FILE. Number 36 and 37 in
the trace are the Delete Directory request and response.  Also have trace
showing the correct return code if needed.
Comment 2 John Bazey 2003-11-13 09:33:35 UTC
Created attachment 254 [details]
Ethereal trace with correct return code (line 36 and 37)

Ethereal trace with correct return code STATUS_DIRECTORY_NOT_EMPTY (lines 36
and 37 in the trace).
Comment 3 Jeremy Allison 2003-12-05 15:37:25 UTC
This was the "bad error code" return bug that I fixed, the one
that caused Excel read-only files not to be opened.
Please try this with Samba 3.0.1rc1. I am pretty sure this
issue is fixed. I cannot reproduce this with the latest CVS SAMBA_3_0
code.
Jeremy.
Comment 4 John Bazey 2003-12-11 07:13:40 UTC
We tried Samba 3.0.1 and everything looks correct.  This bug can now be 
closed. Thanks
Comment 5 Gerald (Jerry) Carter 2005-11-14 09:26:51 UTC
database cleanup