Bug 7702 - Linux client slow against samba server compared to Windows 7
Linux client slow against samba server compared to Windows 7
Status: CLOSED DUPLICATE of bug 7699
Product: Samba 3.4
Classification: Unclassified
Component: Client Tools
3.4.7
Other Linux
: P3 normal
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-28 04:56 UTC by Skokie
Modified: 2010-10-11 01:35 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Skokie 2010-09-28 04:56:37 UTC
Hei, I have stuggled to find any useful information on this topic so I wanted to raise it here (could it be that no one has noticed this phenomenon?)

I have a samba server instance sharing various volumes.  Copying a file over my network results in approx 30MBytes/sec.  For a long time I thought this was normal, but after an accidental use of a new Windows 7 based laptop (I turned it on before installing linux hehe) I see that it gets 80MBytes/sec!

Now since the server is the same, the wire is the same, machine same, switches same etc etc it must come down to the samba linux client.

I have read many things online (samba performance tuning) but nothing seems to affect the linux side performance (other than slowing it).

So 30MBs seems to be a linux limit. Could it be file system performance? no because copying a file locally is much faster (nfs over the network is also faster but lets not complicate things). Nothing I can think of seems to fit the bill unless the samba server side supports new windows extensions that the client side doesnt support (in my version).

For a laugh I shared a ram disk and copied from ram -> network cifs -> ram but still see 30MBs.  The CPU usage is not dramatic so its not some strange linux CPU hogging problem causing the difference.

So I ask here, because I would like linux to be better and because I have no knowlege to find answers myself, why is the linux client so much slower (2.5 x) than windows when its against the same samba server?

Im not sure what information you need but I will try and list the obvious here.

Server side:

:~$ cat /etc/samba/smb.conf 
#======================= Global Settings =======================

[global]
workgroup = HOME
server string = My filesystems
dns proxy = no

log file = /var/log/samba/log.%m
max log size = 1000
syslog only = no
syslog = 0
panic action = /usr/share/samba/panic-action %d
security = user
encrypt passwords = true
passdb backend = tdbsam
obey pam restrictions = yes
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
pam password change = yes
map to guest = bad user

unix extensions = yes
case sensative = yes
ea support = yes

load printers = no
printing = bsd
printcap name = /dev/null
disable spoolss = yes
show add printer wizard = no

########## Misc ################
#socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=65536 SO_SNDBUF=65536

#   domain master = auto

[ media ]
comment = Media storage
path = /store/nonraid/media
valid users = @office @trusted user2
read only = yes
write list = @trusted user2
guest ok = no
oplocks =  yes
browseable = yes
hide files = /lost+found/
map archive = no

Client side information (again sorry if it is incomplete):

fstab entry (current one, tried many performance options), even with defaults the speed is the same:

//myserver/media    /store/services/smb/media    cifs auto,uid=user2,gid=office,rsize=4096,wsize=4096,credentials=/etc/.cred 0 0

Since the exact same hardware is present in both fast and slow cases, I dont see a need to start listing detailed things from a performace perspective, also note that I get the same 30MB/s from my other multi core 7k SATA game system as I do with this new core i3 laptop. Even the SSD on my HTPC shows no difference.

OS Specific details.

Ubuntu 10.04 LTS (all updates applied as of today).
Laptop running Kubuntu, server running Ubuntu server.
Samba 3.4.7

I am really interested to at least find out why this would be and would welcome some feedback or simply ask for more information if needed. I am unable to test samba 3.5 because I do not have access to the packages for debian/ubuntu.

Thanks for reading.
Comment 1 Skokie 2010-09-28 04:57:19 UTC

*** This bug has been marked as a duplicate of bug 7699 ***