Bug 7692 - [PATCH] Cannot find AR when ac_cv_prog_AR is cached
[PATCH] Cannot find AR when ac_cv_prog_AR is cached
Status: CLOSED FIXED
Product: ccache
Classification: Unclassified
Component: ccache
3.1
All Linux
: P3 regression
: 3.1.1
Assigned To: Joel Rosdahl
Joel Rosdahl
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-21 11:37 UTC by Martin Banky
Modified: 2010-11-07 12:07 UTC (History)
1 user (show)

See Also:


Attachments
Patch to fix the error 'cannot find ar' (257 bytes, patch)
2010-09-21 11:39 UTC, Martin Banky
no flags Details
Corrected patch to fix 'cannot find ar' error (230 bytes, patch)
2010-09-21 13:18 UTC, Martin Banky
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Banky 2010-09-21 11:37:47 UTC
When ac_cv_prog_AR is preset or cached, configure cannot find AR. The test 'if test -z "$ac_ct_AR"' will always fail, because the code that sets ac_ct_AR gets completely by-passed.
Comment 1 Martin Banky 2010-09-21 11:39:19 UTC
Created attachment 5972 [details]
Patch to fix the error 'cannot find ar'
Comment 2 Martin Banky 2010-09-21 13:18:28 UTC
Created attachment 5973 [details]
Corrected patch to fix 'cannot find ar' error

Attached the wrong version of the patch. This is the correct one.
Comment 3 Joel Rosdahl 2010-09-22 01:23:46 UTC
Thanks!

Your patch changes the autogenerated part of AC_CHECK_TOOL, so instead, I fixed the test three rows down by testing on $AR instead of $ac_ct_AR:

http://git.samba.org/?p=ccache.git;a=commitdiff;h=e1b287d0ca3cdb48a5d3e8b0d46b9af51ee39abe

Does this work for you?
Comment 4 Martin Banky 2010-09-22 02:20:21 UTC
I don't see why it wouldn't. I was just trying to get past the error message without screwing anything else up in configure. I know just enough about the configure file to be dangerous. I'll test it tomorrow, and let you know if it works.

Martin
Comment 5 Martin Banky 2010-09-24 00:47:41 UTC
OK, I tested it, and it works fine.

Martin
Comment 6 Joel Rosdahl 2010-11-07 12:07:53 UTC
Included in ccache version 3.1.1.