Bug 766 - 'wins hook' broken
'wins hook' broken
Status: RESOLVED DUPLICATE of bug 528
Product: Samba 3.0
Classification: Unclassified
Component: nmbd
All All
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Depends on:
  Show dependency treegraph
Reported: 2003-11-12 13:17 UTC by Harm Kolk
Modified: 2003-11-20 22:12 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Harm Kolk 2003-11-12 13:17:42 UTC
I tried to use the 'wins hook' configuration option to call an external script
for wins updates. It seems that because of '>' in one of the passed variables,
sh errors.

wins support = yes
wins hook = /home/lyon/wins.php

log.nmbd (my externalip has been replaced):
sh: -c: line 1: syntax error near unexpected token `3'
sh: -c: line 1: `/home/lyon/wins.php refresh OFFSHORE<03> 03 259200
sh: -c: line 1: syntax error near unexpected token `20'
sh: -c: line 1: `/home/lyon/wins.php refresh OFFSHORE<20> 20 259200

wins.php is a script, using php to store the var's. There is nothing wrong with
it. (has execution rights, all stuff works)

After looking at the hook code, i noticed that the '>' is detected, but is not
being fixed. I dont think i am good enough with C to fix it though, so i hope
somebody could look into it.
Comment 1 Tim Potter 2003-11-20 22:12:45 UTC
This is fixed in any of the pre-releases and will be in Samba 3.0.1

*** This bug has been marked as a duplicate of 528 ***