Bug 7639 - "inherit owner" does not work due to fail for "change_dir_owner_to_parent" #2
"inherit owner" does not work due to fail for "change_dir_owner_to_parent" #2
Status: RESOLVED DUPLICATE of bug 8211
Product: Samba 3.5
Classification: Unclassified
Component: File services
x86 Linux
: P3 minor
: ---
Assigned To: Volker Lendecke
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2010-08-22 02:41 UTC by TAKAHASHI Motonobu
Modified: 2011-06-15 21:18 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description TAKAHASHI Motonobu 2010-08-22 02:41:19 UTC
"inherit owner" does not work, if inherit acls = yes and the the default ACL for owner 's execute bit is not set.

Is this by design?

To reproduce:

  path = /some/where/share
  writeable = yes
  inherit owner = yes
  inherit acls = yes

; The settings below does not need to reproduce.
; I include these to show why I would like to set these settings.

  dos filemode = yes
  acl group control = yes
  force group = root

  store dos attributes = yes
  map read only = no
  map archive = no

ACL setting:
# getfacl share/
# file: share/
# owner: root
# group: root
default:user::rw- <--- set not to include execute bit

Permission setting:
# ls -l
total 8
drwxrwx---+ 40 root   root   4096 Aug 21 16:52 share

And access as an USER who belongs to "group1" group.

If USER creates any directory under share, the owner of the directory set to the
USER, not to "root".

log.smbd shows:
[2010/08/21 17:30:14.052208,  0] smbd/open.c:290(change_dir_owner_to_parent)
  change_dir_owner_to_parent: failed to change current working directory to New Folder (34). Error was Permission denied
Comment 1 TAKAHASHI Motonobu 2011-06-15 16:10:22 UTC
I tried to reproduce against Samba 3.5.9 and found this issue was fixed. Maybe
this issue is same as BUG#8211.
Comment 2 Björn Jacke 2011-06-15 21:18:57 UTC

*** This bug has been marked as a duplicate of bug 8211 ***