Bug 760 - UniCode named files handling
UniCode named files handling
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.0
All Linux
: P1 enhancement
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-11 20:31 UTC by NetTim
Modified: 2005-11-14 09:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description NetTim 2003-11-11 20:31:13 UTC
I have installed Samba 3.0 on my RedHat 9.0 Host. All UniCode named files copy 
from Windows XP to the Linux Host can working fine both on two systems. But I 
can't use FTP/SSH clients program to access them. I have try to use Internet 
Explorer FTP features, Cute-FTP Pro, WS-FTP, etc. All fails. Is there have any 
resolution on this problem? Those file is contain Traditional/Simple Chinese 
character on their file name.
Comment 1 Andrew Bartlett 2003-11-16 02:13:15 UTC
Samba at it's default settings will use UTF8 to store the filenames.  Your other
applications either need to be configured to also use UTF8, or pick a different
'unix charset'.  UTF8 is the better option, as it can prefectly reflect all of UCS2.

As this is by design, it is not a bug (or more probably, it's a bug in the other
clients/servers or their configuration).

Andrew Bartlett
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:24:28 UTC
database cleanup