Bug 7599 - OpenBSD requires AUTOCONF_VERSION environment variable
OpenBSD requires AUTOCONF_VERSION environment variable
Status: NEW
Product: BuildFarm
Classification: Unclassified
Component: scripts
Other OpenBSD
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2010-07-30 12:08 UTC by John Danks
Modified: 2010-07-30 12:08 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description John Danks 2010-07-30 12:08:43 UTC
OpenBSD supports multiple versions of autoconf installed at the same time and uses a wrapper script (from the metaauto package) to invoke the correct one based on the environment variable AUTOCONF_VERSION. The rsync:HEAD build appears to be failing on configure because this variable isn't set.

The versions of autoconf available on OpenBSD 4.7 are: 2.13, 2.52, 2.54, 2.56, 2.57, 2.58, 2.59, 2.60, 2.61, and 2.62.

This applies to all of the other auto* tools such as automake, autoheader, etc.