Bug 7592 - Unable to generate configure script
Unable to generate configure script
Status: RESOLVED WORKSFORME
Product: Samba 3.5
Classification: Unclassified
Component: Build environment
unspecified
Sparc Solaris
: P3 normal
: ---
Assigned To: Björn Jacke
Samba QA Contact
:
: 7593 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-29 05:01 UTC by Chris Howarth
Modified: 2010-07-29 05:17 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Howarth 2010-07-29 05:01:02 UTC
I am having issues producing the configure script to compile Solaris. In particular:

# ./autogen.sh 
./autogen.sh: running script/mkversion.sh
./script/mkversion.sh: 'include/version.h' created for Samba("3.5.4")
./autogen.sh: running autoheader -Im4 -I../m4 -I../lib/replace -I../source4
../lib/talloc/libtalloc.m4:25: error: AC_CHECK_SIZEOF: requires literal arguments
../../lib/autoconf/types.m4:765: AC_CHECK_SIZEOF is expanded from...
../lib/talloc/libtalloc.m4:25: the top level
autom4te: /usr/local/bin/m4 failed with exit status: 1
autoheader: '/usr/local/bin/autom4te' failed with exit status: 1

As an interim fix, would it be possible for you to send me the configure script ? Asa general comment - any reason why you stopped including the configure script in the source code ? I just ask as to run the autogen.sh script many other packages require installing (autoconf etc...)

Many thanks

Chris
Comment 1 Björn Jacke 2010-07-29 05:06:05 UTC
*** Bug 7593 has been marked as a duplicate of this bug. ***
Comment 2 Björn Jacke 2010-07-29 05:17:46 UTC
I just checked that source3/configure exists in the original 3.4.5 tar ball. It looks like something is broken with your file. Or try to extract the file with GNU tar just in case there is some archive format incompatibility - you never know ...