Bug 759 - Problem compiling samba 3.0.0
Problem compiling samba 3.0.0
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.0
Other other
: P3 normal
: none
Assigned To: Tim Potter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-11 19:56 UTC by Pierre
Modified: 2004-03-02 10:07 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre 2003-11-11 19:56:01 UTC
# gmake
Using FLAGS =  -O3 -march=i686 -I/usr/local/include -I/usr/local/include/libxml2
-I/usr/local/mysql/include/mysql  -Iinclude -I/tmp/samba-3.0.0/source/include
-I/tmp/samba-3.0.0/source/ubiqx -I/tmp/samba-3.0.0/source/smbwrapper  -I.
-D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
-I/usr/local/BerkeleyDB.4.1/include -I/usr/local/include -I/tmp/samba-3.0.0/source
      LIBS = -lcrypt -lresolv -lnsl -ldl
      LDSHFLAGS = -shared  -L/usr/local/BerkeleyDB.4.1/lib -lpthread -lgpm
-Wl,-rpath,/usr/lib
      LDFLAGS = -L/usr/local/BerkeleyDB.4.1/lib -lpthread -lgpm -Wl,-rpath,/usr/lib
Compiling dynconfig.c
In file included from /usr/local/include/krb5.h:2606,
                 from include/includes.h:409,
                 from dynconfig.c:21:
/usr/local/include/com_err.h:75: error: syntax error before "extern"
/usr/local/include/com_err.h:77: error: syntax error before "extern"
/usr/local/include/com_err.h:80: error: syntax error before "extern"
/usr/local/include/com_err.h:82: error: syntax error before "extern"
/usr/local/include/com_err.h:84: error: syntax error before "extern"
In file included from include/includes.h:429,
                 from dynconfig.c:21:
/usr/local/include/gssapi/gssapi.h:473: error: syntax error before "OM_uint32"
/usr/local/include/gssapi/gssapi.h:484: error: syntax error before "OM_uint32"
/usr/local/include/gssapi/gssapi.h:489: error: syntax error before "OM_uint32"
[...]
Comment 1 Gerald (Jerry) Carter 2004-03-02 10:07:33 UTC
There's not enough information here and 3.0.0 is 
really old now.   closing....Please feel free to 
reopen this bug if the problem can be repeoduced on 3.0.2a.  
But please provide more detail.  Thanks.