Bug 755 - smbldap- tools
smbldap- tools
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.0
All Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-11 10:07 UTC by Joseph William Baker
Modified: 2005-11-14 09:26 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph William Baker 2003-11-11 10:07:22 UTC
smbldap-usershow3 joebaker yeilded some strange results when I upgraded
from 3.0.0-1.mdk  to 3.0.1-0.mdk.  It seems to be a break in all sorts of ldap
account maintenance tools.
Here's what I typed and the results as an example...

# smbldap-usershow3 joebaker
Global symbol "$ldapsearch" requires explicit package name at
/usr/lib/perl5/vendor_perl/5.8.0/smbldap_conf3.pm line 228.
Global symbol "$ldapsearchnobind" requires explicit package name at
/usr/lib/perl5/vendor_perl/5.8.0/smbldap_conf3.pm line 229.
Global symbol "$ldappasswd" requires explicit package name at
/usr/lib/perl5/vendor_perl/5.8.0/smbldap_conf3.pm line 231.
Global symbol "$ldapadd" requires explicit package name at
/usr/lib/perl5/vendor_perl/5.8.0/smbldap_conf3.pm line 232.
Global symbol "$ldapdelete" requires explicit package name at
/usr/lib/perl5/vendor_perl/5.8.0/smbldap_conf3.pm line 233.
Global symbol "$ldapmodrdn" requires explicit package name at
/usr/lib/perl5/vendor_perl/5.8.0/smbldap_conf3.pm line 234.
Compilation failed in require at
/usr/lib/perl5/vendor_perl/5.8.0/smbldap_tools3.pm line 4.
BEGIN failed--compilation aborted at
/usr/lib/perl5/vendor_perl/5.8.0/smbldap_tools3.pm line 4.
Compilation failed in require at /usr/bin/smbldap-usershow3 line 29.
BEGIN failed--compilation aborted at /usr/bin/smbldap-usershow3 line 29.

Here's a snippit from my smb.conf file
      ldap suffix =
        ldap machine suffix = ou=Hosts,dc=nelfc,dc=com
        ldap user suffix = ou=People,dc=nelfc,dc=com
        ldap group suffix = ou=Group,dc=nelfc,dc=com
        ldap idmap suffix = ou=Idmap,dc=nelfc,dc=com
        ldap admin dn = cn=root,dc=nelfc,dc=com
        ldap ssl = no
        ldap delete dn = Yes
        message command = /usr/bin/linpopup
Comment 1 Tim Potter 2003-11-12 16:23:05 UTC
*** Bug 756 has been marked as a duplicate of this bug. ***
Comment 2 Gerald (Jerry) Carter 2003-11-24 06:25:59 UTC
bug is against 3.0
Comment 3 Gerald (Jerry) Carter 2003-12-07 21:58:34 UTC
new version of smbldap-tools included in 3.0.1rc1.  
Should be fixed.
Comment 4 Gerald (Jerry) Carter 2005-08-24 10:16:38 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 5 Gerald (Jerry) Carter 2005-11-14 09:26:02 UTC
database cleanup