Bug 7534 - endnetgrent prototype checking is broken for Solaris.
endnetgrent prototype checking is broken for Solaris.
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: Build environment
unspecified
x64 Solaris
: P3 normal
: ---
Assigned To: Kai Blin
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-28 15:33 UTC by Ira Cooper
Modified: 2010-07-07 02:32 UTC (History)
1 user (show)

See Also:
kai: review-


Attachments
proposed patch. (3.36 KB, patch)
2010-06-28 15:34 UTC, Ira Cooper
no flags Details
Attempt to fix *netgrent prototype detection on Solaris (2.26 KB, patch)
2010-07-02 15:45 UTC, Kai Blin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ira Cooper 2010-06-28 15:33:41 UTC
This is because there is no netgroup.h on Solaris.

In reading the man pages for *netgrent on Solaris, Linux and OSX, none say netgroup.h is required.

Proposed patch to remove the reference is included.  The wscript change is a guess because I do not use waf.

Thanks,

-Ira
Comment 1 Ira Cooper 2010-06-28 15:34:37 UTC
Created attachment 5814 [details]
proposed patch.
Comment 2 Ira Cooper 2010-06-30 07:40:34 UTC
Kai,

I suspect this regression came from, 7a1c2470, which I tracked back to you.

Could you please review what I have here, and work with me to get a fix into the tree?

Thanks,

-Ira
Comment 3 Kai Blin 2010-06-30 08:02:48 UTC
Sorry, this will break the NetBSD5 box in the build farm. I had to add that additional header to get the prototypes on NetBSD. We obviously need a more complicated check. This patch won't work as is, though.
Comment 4 Kai Blin 2010-07-02 15:45:00 UTC
Created attachment 5819 [details]
Attempt to fix *netgrent prototype detection on Solaris

Please check if this patch works for you on Solaris.
Comment 5 Ira Cooper 2010-07-06 09:34:13 UTC
Looks good from here Kai.  It passes build here.

Thanks,

-Ira
Comment 6 Kai Blin 2010-07-07 02:32:42 UTC
Fixed in master by commit 0b6cebd60288b37f28176e24abeb20109dfd70e5 then.