Bug 748 - sambalp too strict on argv parsing
sambalp too strict on argv parsing
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Packaging
3.0.0
SGI IRIX
: P3 minor
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-09 19:23 UTC by James Peach (outdated mail address)
Modified: 2005-08-24 10:17 UTC (History)
0 users

See Also:


Attachments
Patch to make argv parsing less strict. (679 bytes, patch)
2003-11-09 19:27 UTC, James Peach (outdated mail address)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Peach (outdated mail address) 2003-11-09 19:23:54 UTC
I just upgraded to samba3 and found that printing stopped working because
the %U substitution was not being made on my print command. I presume that
this is caused by using MS_RPC instead of NetBIOS for printing(?).

At any rate, printing failed because the sambalp command wasn't getting 
enough command line arguments. However, the last two arguments are not
really necessary, so it would be more robust to allow them to be empty.
Comment 1 James Peach (outdated mail address) 2003-11-09 19:27:06 UTC
Created attachment 245 [details]
Patch to make argv parsing less strict.

This patch defaults the user and machine arguments to the
sambalp script and makes them optional.
Comment 2 Gerald (Jerry) Carter 2004-03-16 11:44:49 UTC
got it.
Comment 3 Gerald (Jerry) Carter 2005-08-24 10:17:05 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.