Bug 7477 - configure incorrectly 'detects' stdbool.h
configure incorrectly 'detects' stdbool.h
Status: RESOLVED FIXED
Product: Samba 3.5
Classification: Unclassified
Component: Build environment
3.5.3
Other Other
: P3 normal
: ---
Assigned To: Björn Jacke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 02:59 UTC by Joachim Schmitz
Modified: 2012-09-17 12:47 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joachim Schmitz 2010-05-28 02:59:54 UTC
confirure incorrectly 'detects' stdbool.h and sets HAVE_STDBOOL in .../source3/include/config.h.
I had to get rid of it manualy:

diff -u ./source3/include/config.h.orig ./source3/include/config.h
--- ./source3/include/config.h.orig	2010-05-26 09:28:24.000000000 -0500
+++ ./source3/include/config.h	2010-05-26 09:38:35.000000000 -0500
@@ -2116,7 +2116,9 @@
 #define HAVE_STDARG_H 1
 
 /* Define to 1 if you have the <stdbool.h> header file. */
+#ifndef __TANDEM /* wrongly recognized? */
 #define HAVE_STDBOOL_H 1
+#endif
 
 /* Define to 1 if you have the <stdint.h> header file. */
 #define HAVE_STDINT_H 1


But I'm well aware thai this is not the proper fix...

Nye, Jojo
Comment 1 Joachim Schmitz 2010-05-30 12:21:39 UTC
Forget about it, I must have made some mistake, as an attempt to reproduce this failed miserably, 'configure' does detect the absence of stdbool.h and reflects that in config.h.
Guess I missee a 'make clean' between two 'configure' runs and the 2nd one deteted stdbool.h in ...lib/replace.

See also bug 7461, which I believe can also get closed (I'm verifying this at the moment).

Bye, Jojo
Comment 2 Björn Jacke 2010-06-16 16:47:48 UTC
do we actually require to run a make clean before each configure?

Shouldn't libreplace's configure see that the found stdbool.h is its own one and not throw its that one away after it found it? :-)
Comment 3 Joachim Schmitz 2010-06-17 00:41:11 UTC
Well, I was only guessing what might have gone wrong. I couldn't reproduce it later. That's why I closed the bug.
But if you have ideas what went wrong and how to fix, I'd not be agaist it...


Comment 4 Björn Jacke 2010-06-17 03:51:27 UTC
this is a problem we see on other machines, too. I also stumbed over it on IRIX and another machine recently. Metze or Jelmer - do you have an idea how to easily limit the search for header files to the system include directories only and prevent that libreplace finds its own generated header files?
Comment 5 Jelmer Vernooij 2010-06-28 06:42:33 UTC
I guess the issue is that we shouldn't have lib/replace in the include paths during configure - we weren't doing so in the past at least. Is there any reason why we need to do so now?