Bug 7458 - joining to s4 domain does not register correct dnshostname
joining to s4 domain does not register correct dnshostname
Status: RESOLVED WORKSFORME
Product: Samba 3.5
Classification: Unclassified
Component: Client Tools
3.5.2
Other Linux
: P3 normal
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 15:52 UTC by Matthieu Patou
Modified: 2015-12-08 19:02 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthieu Patou 2010-05-26 15:52:18 UTC
Upon join s3.5.x sometime register correct fqdn as the value of the attribute dnsHostName.
Sometimes it don't and just put the short netbios name.
Comment 1 Matthieu Patou 2012-03-17 07:23:07 UTC
Is it fixed?
If not, I think it should be done for a 4.0 release
Comment 2 Michael Adam 2012-11-01 13:19:44 UTC
Is this a duplicate of bug #7466 ?

Also, is this a bug in the 3.5 client tool (in which case it can't block the 4.0 release) or is it a bug in samba 4.0.0rcX ?
Comment 3 Matthieu Patou 2012-11-01 17:48:27 UTC
No it was not.
From what I see in my latest tests is that samba does try to register the correct fullname.

It might be still a bug in 3.5 I need to recheck
Comment 4 Matthieu Patou 2012-11-06 10:19:56 UTC
Cross-checked with samba 4.0r3 FS it tries to use the correct fqdn.
I'll recheck with S3.5, hence removing the blocker for 4.0
Comment 5 Björn Jacke 2015-12-08 19:02:27 UTC
i have't seen this bug in any recent samba version. check hostname and hostname -f also cause this matters for the dns name registration.