Bug 7431 - net ads keytab create didn't add an entry for host/fqdn anymore
net ads keytab create didn't add an entry for host/fqdn anymore
Status: RESOLVED FIXED
Product: Samba 3.5
Classification: Unclassified
Component: Client Tools
3.5.2
x86 Linux
: P3 normal
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-17 16:27 UTC by Matthieu Patou
Modified: 2011-11-18 14:33 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthieu Patou 2010-05-17 16:27:08 UTC
In Samba 3.2.5 and Samba 3.4.7 doing net ads keytab create used to create entry for SPN host/fqdn.

In samba 3.5.0rc3 and 3.5.2 I don't have this entry anymore (but others like host/server and host/netbiosname are ok).

I tried to tweak by using this:

kerberos method 
* secrets only
* secrets and keytab

But it seems to be without results.
Comment 1 Matthieu Patou 2010-05-23 02:28:03 UTC
After some investigation in the code it seems that the problem is due to the fact that dnshostname sometime didn't contain the fqdn.
Comment 2 Matthieu Patou 2011-11-18 14:33:00 UTC
Fixed