Bug 7426 - --files-from= broken when run from crontab
--files-from= broken when run from crontab
Status: RESOLVED DUPLICATE of bug 7425
Product: rsync
Classification: Unclassified
Component: core
x64 Linux
: P3 regression
: ---
Assigned To: Wayne Davison
Rsync QA Contact
Depends on:
  Show dependency treegraph
Reported: 2010-05-13 02:23 UTC by Joshua Smith
Modified: 2010-05-13 11:45 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Joshua Smith 2010-05-13 02:23:24 UTC
running rsync version 3.0.7 (also tried rsync-HEAD-20100501-0829GMT) debian lenny amd64, if i call a shell script with the content:
rsync -a -e 'ssh -i /home/mapsync/.ssh/id_rsa' --bwlimit=1221 --files-from=/tmp/tf2maplist --no-relative / mapsync@foo.com:/home/mapsync/tf2maps

Everything runs great from a shell. /tmp/tf2maplist is a file which contains one line at a time the location of all the .bsp files found in /home, here is a snippet from /tmp/tf2maplist:


When run from the root crontab this error occurs:
rsync: change_dir "/root/home/user1/srcds_l/orangebox/tf/maps" failed: No such file or directory (2)

How do i stop rsync from prepending /root/ to the front of every line when run from cron? Thanks!
Comment 1 Matt McCutchen 2010-05-13 11:45:58 UTC

*** This bug has been marked as a duplicate of bug 7425 ***