Bug 7420 - Does not work with VirtualBox and Ubuntu
Does not work with VirtualBox and Ubuntu
Product: Samba 3.4
Classification: Unclassified
Component: File services
x64 Other
: P3 normal
: ---
Assigned To: Volker Lendecke
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2010-05-10 18:40 UTC by Yigal Spinner
Modified: 2010-09-21 00:07 UTC (History)
0 users

See Also:

Samba configuration (12.15 KB, text/plain)
2010-05-12 14:24 UTC, Yigal Spinner
no flags Details
The current log file (1.35 KB, text/plain)
2010-05-12 14:25 UTC, Yigal Spinner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yigal Spinner 2010-05-10 18:40:59 UTC
I have the following configuration:
1. Host system: Windows 7 64 bit
2. VirtualBox 3.1.6
3. Guest system Ubuntu 9.10 64bit

I have shared one of the Windows drive using the VirtualBox "Share Drive" feature and then used Samba 4 to share the drive to other devices. This way other devices that do not recognize Windows 7 (like EVA 8000) can use the shared drive to get to the media files.
This worked fine until the new release of Samba this stop working. I updated my Ubuntu with the latest update and it broke the configuration.
The error in Samaba is about file can not be accessed

 [2010/05/10 18:32:56,  0] param/loadparm.c:8561(process_usershare_file)
  process_usershare_file: stat of /var/lib/samba/usershares/dvdmovies failed. Permission denied

I tried to install the latest Ubuntu 10.4 and configure the same way, but it does not work.
I had an old Ubuntu 32 bit that was not updated with the latest Samba and it does continue to work. This means it is not VirtualBox.

Any ideas how to fix this issue?

Comment 1 Andrew Bartlett 2010-05-10 18:52:21 UTC
Which exact version of Samba4 were you using successfully in the past, and how exactly are you using Samba4?

Please also supply the working and failing configuration files, and any other details that may assist in understanding exactly what you are doing and what you expect to achieve.

Comment 2 Yigal Spinner 2010-05-12 14:24:16 UTC
Created attachment 5702 [details]
Samba configuration
Comment 3 Yigal Spinner 2010-05-12 14:25:12 UTC
Created attachment 5703 [details]
The current log file

This log shows that an external computer is trying to map to the exported diretory and fails.
Comment 4 Yigal Spinner 2010-05-12 14:28:15 UTC
The smdb version is 3.4.0.
After updating the Ubuntu to the latest version, it stop sharing the directory.

I use VirtualBox for guest system Ubuntu 9.10 64 bit.
In VirtualBox, I use the share drive option to allow a windows drive to be mounted in the Unix environment (using the mount command).
I use samba to share the subdirectories of the drive to other computers.
Comment 5 Andrew Bartlett 2010-05-12 16:41:44 UTC
Reassigning to 3.4 per comment
Comment 6 Volker Lendecke 2010-05-12 17:06:14 UTC
Please upload a debug level 10 log of the failure.


Comment 7 Volker Lendecke 2010-09-21 00:07:10 UTC
Please add the user you are connecting as to the group "sambashare".