Bug 7397 - On computer rename or dns change SPN HOST/Netbios and HOST/fqdn must be changed
On computer rename or dns change SPN HOST/Netbios and HOST/fqdn must be changed
Product: Samba 4.0
Classification: Unclassified
Other Linux
: P3 normal
: ---
Assigned To: Andrew Bartlett
Depends on:
  Show dependency treegraph
Reported: 2010-04-27 09:50 UTC by Matthieu Patou
Modified: 2010-11-01 12:47 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Matthieu Patou 2010-04-27 09:50:51 UTC
Currently with a windows workstation member of the domain if you change the name of the workstation (my computer -> property -> computer name) the SPN associated to the workstation are not changed (which cause problems then when user logs in).

I suppose that when the netbios name is changed that the associated SPN must be changed too.
Also if the workstation change its dnshostname record the associated SPN must be changed too (at least HOST/newfqdn).
Comment 1 Matthias Dieter Wallnöfer 2010-05-03 08:23:39 UTC
Can you reproduce this behaviour on a Windows Server (SPN name change after long and short hostname change)?
Comment 2 Matthieu Patou 2010-05-05 01:23:16 UTC
Hi Matthias, 
here is the result of ldbsearch -H ldap://w2k8r2 server '(objectClass=Computer)' servicePrincipalName

dn: CN=ARESXP1,CN=Computers,DC=w2k8r2,DC=matws,DC=net
servicePrincipalName: HOST/ARESXP1
servicePrincipalName: HOST/aresxp1.w2k8r2.matws.net

And just after changing the name (but before reboot):

dn: CN=ARESXP1_NEW,CN=Computers,DC=w2k8r2,DC=matws,DC=net
servicePrincipalName: HOST/aresxp1_new.w2k8r2.matws.net
servicePrincipalName: HOST/ARESXP1_NEW

Of course I changed the name from aresxp1 to aresxp1_new 
Comment 3 Matthieu Patou 2010-10-27 13:54:15 UTC
Any news ?
Any plan to fix this bug ? 
Comment 4 Matthias Dieter Wallnöfer 2010-10-27 15:13:02 UTC
ekacnet, I plan to start working on this but it can take some time.
Comment 5 Matthias Dieter Wallnöfer 2010-11-01 12:47:18 UTC
This should have been fixed by a recent patch of mine.