Bug 7380 - rsync not backing up certain binaries
rsync not backing up certain binaries
Status: RESOLVED INVALID
Product: rsync
Classification: Unclassified
Component: core
2.5.7
x86 Linux
: P3 major
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-21 12:08 UTC by Joshua
Modified: 2010-04-21 12:40 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joshua 2010-04-21 12:08:11 UTC
I am rsyncing directories from one system to the other for nightly backups, I have noticed it refuses to copy some binaries even though they have different sizes, dates and checksum, i even tried with the -c option. The file "runcbl" is the one that is different.

Here is what is happening:
[root@inqdbvm RWzzz]# /usr/bin/rsync -aucvx --rsh="ssh" --delete aries3:/RWzzz /Backup/aries3
root@aries3's password: 
receiving file list ... done
RWzzz/AP01/APFAUX01.DAT
RWzzz/AP01/APNOTF01.DAT
RWzzz/AP01/APRCUR01.DAT
RWzzz/AP01/PCOFIL01.DAT
RWzzz/AP01/VENFIL01.DAT
RWzzz/RWWRK/
RWzzz/AR02/CUSFIL02.DAT
RWzzz/AR02/CUSFIL02.vix
wrote 56072 bytes  read 218126 bytes  4853.06 bytes/sec
total size is 2212191051  speedup is 8067.86

[root@inqdbvm RWzzz]# ls -la /Backup/aries3/RWzzz/runcbl
-rwxrwxrwx    1 root     root      1647880 Oct 15  2008 /Backup/aries3/RWzzz/runcbl

[root@aries3 RWzzz]# ls -la /RWzzz/runcbl
-rwxrwxrwx    1 root     root      2205724 Jul 21  2008 /RWzzz/runcbl

[root@inqdbvm RWzzz]# file runcbl
runcbl: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.2.5, dynamically linked (uses shared libs), stripped
Comment 1 Matt McCutchen 2010-04-21 12:17:15 UTC
Rsync 2.5.7 is six years old; we won't support it.  If you're using an "enterprise" OS distribution, you can ask the vendor.  Otherwise, please upgrade rsync.
Comment 2 Joshua 2010-04-21 12:27:43 UTC
Attempted in 3.0.7, same issue.
Comment 3 Matt McCutchen 2010-04-21 12:34:04 UTC
Ah.  You are using the -u option, which tells rsync not to replace the newer destination file with the older source file.  If that's not what you want, remove the -u option.
Comment 4 Joshua 2010-04-21 12:40:24 UTC
Thanks, I saw that just now, I'm unsure how the backup file got modified to be newer than the one running but that solved it!